Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to create a Vagrant Basebox for Debian Lenny.

The first step in this process is creating a VM Guest in Virtualbox. I've created a new VM image and begun installation of Debian Lenny using the netinst image.

However, the VM refuses to connect to the network.

My Ubuntu host has a standard ethernet network connection with full internet access.

After configuring the root and non-root users, the non-GUI installer prompts me to select a mirror for downloading additional packages.

Regardless of the mirror seleceted, the following message is displayed:

Bad archive mirror The specified Debian archive mirror is either not available, or does not hae a valid Release file on it. Please try a different mirror.

I have tried 2 network configurations for the VM Guest by right-clicking on the guest item listed in VirtualBox Manager -> Settings -> Network. The first is the default configuration, this being:

Attached to: NAT

The second was:

Attached to: Bridged Adapter

Name: eth0

Promiscuous Mode: Deny

Neither has any effect.

I chose to continue the installation anyway, so am now in the Lenny guest OS.

Is there a simple fix to enable networking for this VM?

Sincere thanks for your time.

share|improve this question
    
What did you see in the virtual terminal '4' as error ? To switch you need to enter ALT+F4 and ALT+F1 to restore to first. I bet you'll see an error about getting the 'Release' file on mirror which I've been also bitten by. So, it's not a network issue. –  user156135 May 6 '13 at 15:25

1 Answer 1

If the problem is with network interface driver in guest OS, try changing adapter type in VirtualBox Manager -> Settings -> Network -> Advanced. I had similar problem with windows as guest and choosing PCnet-PCI II solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.