Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 12.10 and I want to map the show-desktop keybinding to Super+d. I tried to configure it in Compiz configuration manager, in the system properties-keyboard configuration and in dconf-editor but without success. After each reboot the value of the dconf entry is reset to the default value <primary><super><d>.

I really don't know what to do now :P

share|improve this question
add comment

1 Answer

I can recreate your problem in 12.10 if I change the setting through System Settings >> Keyboard >> Shortcuts.

This is probably related to Bug #936840 about the change in Gnome from using <ctrl> to using <primary>. Note that the setting in System Settings is given as Ctrl+Super+D, so the setting is probably no longer going through correctly.

When I left the setting in System Settings alone and made the change from CompizConfig or Dconf, the change held across reboots. Note that these two programs, use <Control><Primary><Super>d, so they apparently are able to hook the settings daemon correctly.

If you are still having trouble, try resetting System Settings to the default, rebooting, and then making the change from CompizConfig.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.