Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to have thumbnails for text files in Nautilus but I don't have them anymore. I'm on Ubuntu 12.10, I haven't disabled them as per How to stop Nautilus from creating thumbnails of specific file types? and they are displayed for other file types like pdf and videos.

share|improve this question
    
Do you mean something like this? –  Lucio Apr 5 '13 at 0:00
    
Exactly. Exactly. –  sup Apr 5 '13 at 0:01

2 Answers 2

up vote 4 down vote accepted

This is a bug. As all the icons in question were all in a Ubuntu One synchronized folder, the live text preview (which works differently for text files and for other filetypes, hence the inability of scripts to regenerate thumbnails to make thumbnails of text files) does not work because Ubuntu one uses emblems and they break the live text preview.

share|improve this answer

To have an icon with a preview text for all the text files, follow this steps:

  1. Open the Preferences menu in the Edit tab
  2. Click the Preview tab
  3. Now you will see that the first option is "Show text in icons", choice it and select Always

Result:

screenshoot

share|improve this answer
    
I have already tried that and it does not work:-/. –  sup Apr 5 '13 at 0:03
1  
In this case you should check exactly the configurations that you made using dconf and try to disable and revert it. –  Lucio Apr 5 '13 at 0:04
    
Hm, I am fiddling with it but with no succes. There do not seem to be so many options related to it. But it works with a guest account so I guess I will try some form of bisection. Thanks for the pointers! –  sup Apr 5 '13 at 0:09
1  
Renaming my .config/dconf resets my settings but does not bring thumbnails. I tried to use James Henstridge's script from askubuntu.com/questions/199110/… but it complains it cannot preview text/plain, which puzzles me deeply. –  sup Apr 5 '13 at 0:47
    
So it turns out to be a bug (see my answer for details). –  sup Apr 5 '13 at 10:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.