Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two visible boot partitions, one of which is historical only, so I wanted to stop GRUB from creating boot menu options for it. I renamed /boot and moved /vmlinux and /initrd.img away from it's root. Then I ran update-grub. All seemed well until I rebooted, when GRUB reported "file not found" and dropped into grub rescue.

My active system is Xubuntu 12.04, fresh install. The historical one is Ubuntu 11.10.

Looking at other questions and answers here, I tried

set prefix=(hd2,msdos2)/boot/grub
set root=(hd2,msdos2)
ls /boot
insmod /boot/grub/linux.mod

(at which point the font color changed to intense white) i continued with

linux /vmlinuz root=/dev/sda2 ro
initrd /initrd.img

(at which point, grub rescue started giving the error message "no such partition", even to repeats of the insmod or linux commands above).

What did I do wrong?

share|improve this question
I should add that after entering the initrd command the results of the ls command turn into just (hd0)(hd1)(hd2) without any partitions showing. – ForDummies Apr 4 '13 at 21:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.