Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Xubuntu, icons in desktop don't show their emblems, no matter if they are links, directories or files. They appear to be ok in thunar and nautilus for the same files/directories.

How can I make emblems appear in desktop?

I use Xubuntu 12.10 and xfce 4.12.

share|improve this question
add comment

1 Answer

The short answer is that you can't show emblems on icons on the desktop with the normal xfdesktop package at the present time, although there is a development patch available. On Xfce, xfdesktop actually manages the desktop and not thunar, the filemanager. If you go to settings > settings-manager > desktop > icons, there are few options to tweak the desktop icon setup, but no other hidden ones within xfconf-query under xfce4-desktop. It is possible to show thumbnails of items on the desktop because thumbnailing on Xfce is managed by default by another service called tumbler and not by xfdesktop or thunar by themselves.

However, there is a development patch for custom emblems at Xfce.org. Eric Koegel wrote in the patch summary that it:

Adds support to display multiple custom emblems for file icons on the desktop. Regular file icons will display whether it's a symlink or the file is read-only in addition to any emblems the user sets in Thunar. This requires an optional dependency on libtdb to read the metadata for the user set emblems.

You must use git to clone the source, as the patch is set up to work with the source directly from git.

(This was tested with on Ubuntu 12.04 with the Xfce 4.10 and 4.12 ppas applied, not with the stock Precise version, so it should work on 12.10 and later also)

Please Note: The feature is very experimental, so it is up to you if you want to try it, and perhaps report back upstream if you have problems.

sudo apt-get install libtdb1 libtdb-dev git build-essential checkinstall xfce4-dev-tools
sudo apt-get build-dep xfdesktop4
git clone git://git.xfce.org/xfce/xfdesktop
cd xfdesktop
wget "https://bugzilla.xfce.org/attachment.cgi?id=4391" --output-document=xfdesktop4.patch
patch -p1 < xfdesktop4.patch
./autogen.sh --prefix=/usr
make
sudo apt-get autoremove --purge xfdesktop4 xfdesktop4-data 
sudo checkinstall --pkgversion=4.10.3

Note: When the configure has finished, you should get this message (see the icon emblems part):

Build Configuration:
* Build desktop menu module:                    yes
* Build support for desktop icons:              yes
      Include support for file/launcher icons:  yes
      Include support for icon emblems:         yes
* Special treatment for mount points on UNIX:   yes
* Mount notification support:                   yes

Now after installation run xfdesktop --version and you will get:

Built with GTK+ 2.24.10, linked with GTK+ 2.24.10.
Build options:
    Desktop Menu:        enabled
    Desktop Icons:       enabled
    Desktop File Icons:  enabled
    Custom Icon Emblems: enabled

Lastly, logout and login again, as xfdesktop --reload won't be enough, and the emblems should be there. If xfdesktop is not running when you log back in, enter xfdesktop & and it will start. For a more permanent solution, add it as a startup item, as it should be starting up on login.

Be aware that this is development code (both the patch and the git code) and hasn't been classed as a stable version, so it might not always work as expected, but this is about all that is possible at the minute. Also, when you get a later version through any updates, it may remove your patched version unless you pin the version in apt settings.

I have experimented with the new version of xfdesktop and successfully returned to the old version by simply removing the package installed with checkinstall- it will be called something like xfdesktop4.10.3, but just type xfdesktop and press tab until the package appears. As an example, you could use

sudo apt-get autoremove --purge xfdesktop_4.10.3

Then just reinstall xfdesktop4 and xfdesktop4-data. The xfdesktop package is obviously not as critical as a window manager, but perhaps experiment on a virtual machine beforehand if you wish.

I can say that the emblems are quite small, although the symlink symbol can just be seen, although not all emblems appear, so it is clearly a very experimental feature. Emblems appeared on file icons, but not on folder icons.

share|improve this answer
    
Thank you for the quick and detailed answer, I will try it. But first: what if I want to go back to the current state? If, for example, something go really bad? –  MakisH Apr 4 '13 at 19:57
    
@MakisH Good point, I was just about to add some further details. –  user76204 Apr 4 '13 at 20:06
    
I tried it in a Virtual Machine (Xubuntu 12.10 64bit, xfce 4.10). It works for both files and folders (needs a refresh every time I change an emblem). BUT it crashes every time I log in and it loads normally if I ask to "relaunch". Also, it seems to forget the wallpaper "style" (centered, stretched etc) at least. Further feedback: trying to run "autogen.sh", it asked for xfce4-dev-tools, I installed it. Thank you again for the response, but I prefer not to try it to my main system. I hope this feature be included in a next version of xfce. Tell me if I can help with more feedback. :-) –  MakisH Apr 6 '13 at 21:18
    
@MakisH Yes, it is a very experimental feature and there are problems with it, and that's why it's not in xfdesktop git master branch, but it was worth testing. I'll add the xfce4-dev-tools to the install list, as you do need those. –  user76204 Apr 6 '13 at 21:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.