Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i've got a vhost running ubuntu 12.10. i installed davfs2 and edited my /etc/fstab file like the following:

https://somedomain.de/webdav.php/somefolder/ /mnt/s02 davfs defaults 0 0

now mounting this using mount -a works fine. also if i type reboot after connecting using ssh on my vhost as root user, my drive gets mounted correctly.

but using the web-backend of my provider (digitalocean) and clicking "reboot" there, i get an error after my machine starts up:

failed boot

any ideas why this is happening and how to fix this?

share|improve this question

1 Answer 1

up vote 5 down vote accepted
+50

The error Could not resolve hostname 'hostname.de': host not found probably means the network is not up while trying to mount.

It is recommended to set the _netdev mount option that means: device requires network to be available. This way, it will wait until there is a link available before trying to mount:

https://somedomain.de/webdav.php/somefolder/ /mnt/s02 davfs defaults,_netdev 0 0
share|improve this answer
    
♥ works like a charm. thank you! totally worth the bounty. –  choise Apr 13 '13 at 1:50
    
@choise you forgot to award me the bounty, lol. –  Teresa e Junior Apr 15 '13 at 4:31
    
done. thought this happens automatically –  choise Apr 15 '13 at 8:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.