Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So a couple of days ago, I had my laptop hooked up to my tv via HDMI. I used pavucontrol to disable sound on my laptop and play it through the tv. I changed it back when I was done. Can't remember if I used it right away. Last night I tried to use it and it didn't work. I opened pavucontrol again and switched to the configuration tab where there had previously been a drop down menu allowing me to choose what device to output my sound through. Now there's nothing. It says no card available for configuration. When I open asoundconf-gtk it only has "PCH" and selecting that does nothing either.

Here is my output of pulseaudio -d http://pastebin.com/75SpLihg

And using the guide on the Ubuntu Wiki Pulse Audio page, I made a log http://pastebin.com/rmARXUMD

I've tried deleting the pulse folder from my home directory and restarting the server. After searching on Google, I found similar problems required me to edit /etc/pulse/client.conf and make sure autospawn is set to yes and everything is commented out with a semicolon, which it is. Tried using qasmixer to make sure sound isn't disabled. Nothing works. . I've tried posting on the Ubuntu-Forums.org site and got no help there so I'm trying here because I dont want to reboot into Win7 to stream videos or listen to my mp3s.

Since I don't have reputation for more links, I'll post in the comments for my client and daemon conf files.

Running Lubuntu 12.10 with kernel 3.5.0-24-generic. I hope this is enough info.

Edit: July 29th/13: I decided to create a new user account and everything shows up as normal in pavucontrol. I am able to see the sound card and adjust settings although I didn't actually test the sound. So this appears to be a user configuration error (although if I run gksudo pavucontrol, I still cant access the sound card). I've deleted ~/.pulse as well as the pulse in ~/.config. Still nothing. Not sure what else to delete.

share|improve this question
    
Here is the client.conf pastebin.com/ahWxXB5X Here is the daemon.conf pastebin.com/gRyCsjdb – Rob Fitz Apr 4 '13 at 13:15
    
And here is pulse syslog pastebin.com/ySgnNmEb I assume it can't find the files because I deleted the pulse folder from /tmp? – Rob Fitz Apr 4 '13 at 13:20

I've finally solved it. I deleted any asoundconf files from my home directory after testing the new user theory. Then I just killed and restarted pulseaudio and everything came back!

share|improve this answer
    
Just to add to this answer, my solution (Yes, I had this problem on Ubuntu 15.04) was to delete ~/.config/pulse (actually I renamed it, just in case) and then start pulseaudio again using pulseaudio -D. – Nahuel Oct 16 '15 at 14:43

Try to uninstall pulseaudio with sudo apt-get purge pulseaudio and then reinstalling it again.

share|improve this answer
    
That was my last idea. I was just hoping there would be something else. I did that and restarted pulseaudio but it didn't work. The only other idea I have is to just reboot. – Rob Fitz Apr 4 '13 at 15:11
    
Try changing the /etc/pulse/client.conf to: default-sink = alsa_output.pci-0000_00_1b.0.analog-stereo – SJG Apr 4 '13 at 17:50
    
No luck there either :( – Rob Fitz Apr 5 '13 at 12:17
    
Any other ideas? – Rob Fitz Apr 14 '13 at 16:34

Well, this worked for me and it is really easy :

  1. Open PulseAudio Volume Control (open a terminal and type pavucontrol). Install it if you don't have it.
  2. When you open it, go to "Configuration" : For one of the "built in audios" one has HDMI (unplugged) in front of "Profile". Choose "Off" for that profile.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.