Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using apt-get update I am getting

Err http://ppa.launchpad.net precise/main amd64 Packages              
404  Not Found

W: Failed to fetch
http://ppa.launchpad.net/webupd8team/jupiter/ubuntu/dists/precise/main/binary-amd64/Packages
404  Not Found

E: Some index files failed to download. They have been ignored, or old
ones used instead.

The machine is behind proxy and proxy is configures correctly and the error is not coming for other packages fetched from the internet. It is more common with ppas. Never got a problem with other sources.

had the problem with:

deb http://_ppa.launchpad.net/rabbitvcs/ppa/ubuntu precise main
deb [arch=amd64] http:__ppa.launchpad.net/webupd8team/jupiter/ubuntu precise main

also tried using Acquire::http {No-Cache=True;}; and treid cleaning the cache of list sudo rm /var/lib/apt/lists/*

Nothing worked out. The url that fails opens perfectly in browser or using wget.

This problem only happens when using proxy.

share|improve this question

1 Answer 1

Not sure what kind of Ubuntu and version you are using.

Ubuntu has proxy switcher, where you can choose -- apply systemwide -- like button. Then apt should work behind proxy with no problem.

Xubuntu and other non-gnome clones don’t have any proxy switcher, so there is necessary to update /etc/apt/apt.conf.d/proxies95 file where should be following:

Acquire::http::proxy "http://proxyIP:port/";
Acquire::ftp::proxy "ftp://proxyIP:port/";
Acquire::https::proxy "https://proxyIP:port/";

this will work specifically for apt-get command. Hope this will solve it, if not, tell us.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.