Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running a FOG server and added many hacks to my pxe menu but now I want to add DRBL Live but it doesn't work

I tried that with this pxe configuration

LABEL fog.drbl
    MENU PASSWD $1$b1E5ld/w$nRekAlrkmtRfofb4ZJC7L1
    kernel fog/drbl/live/vmlinuz boot=live config nomodeset vga=785 ip=frommedia nosplash
    append initrd=fog/drbl/live/initrd.img
    MENU LABEL DRBL Live
    TEXT HELP
    Start Live DRBL server with clonezilla live &  clonezilla server options
    ENDTEXT

I get initrd.img and vmlinuz from the iso of DRBL Live and the parameters from the grub configurations in there $DRBLiso/EFI/boot/grub.cfg.

When booting to DRBL option I get the following errors :

dprobe: module unknown not found in modules.dep
dprobe: module unknown not found in modules.dep
dprobe: module unknown not found in modules.dep
dprobe: module unknown not found in modules.dep
dprobe: module unknown not found in modules.dep
dprobe: module unknown not found in modules.dep
dprobe: module unknown not found in modules.dep
dprobe: module unknown not found in modules.dep
dprobe: module swap not found in modules.dep

can anyone see what's wrong here ?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Well .. it works like magic !

I added the file filesystem.squashfs to my webserver root and modified the thrid line :

kernel fog/drbl/live/vmlinuz boot=live config nomodeset vga=785 ip=frommedia nosplash fetch=http://MYWEBSERVERIP/filesystem.squashfs
share|improve this answer
label DRBL Live
MENU DEFAULT
# MENU HIDE
MENU LABEL DRBL Live (Default settings)
# MENU PASSWD
kernel drbl/live/vmlinuz
append initrd=drbl/live/initrd.img boot=live config nomodeset vga=785 ip=dhcp nosplash netboot=nfs nfsroot=192.168.1.91:/var/lib/tftpboot/drbl i915.blacklist=yes radeonhd.blacklist=yes nouveau.blacklist=yes vmwgfx.blacklist=yes
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.