Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I failed to install qt4-designer under ubuntu 12.10 because I got this error message:

qt4-designer:
  Depends: libqt4-designer (=4:4.8.3+dfsg-0ubuntu3.1) but 4:4.8.3+dfsg-0ubuntu4~quantal1~test4 is to be installed
  Depends: libqt4-network (=4:4.8.3+dfsg-0ubuntu3.1) but 4:4.8.3+dfsg-0ubuntu4~quantal1~test4 is to be installed
  Depends: libqt4-xml (=4:4.8.3+dfsg-0ubuntu3.1) but 4:4.8.3+dfsg-0ubuntu4~quantal1~test4 is to be installed
  Depends: libqtcore4 (=4:4.8.3+dfsg-0ubuntu3.1) but 4:4.8.3+dfsg-0ubuntu4~quantal1~test4 is to be installed
  Depends: libqtgui4 (=4:4.8.3+dfsg-0ubuntu3.1) but 4:4.8.3+dfsg-0ubuntu4~quantal1~test4 is to be installed

How can I fix this issue?

share|improve this question

marked as duplicate by Thomas W., Seth, Raja, Eric Carvalho, Caesium Apr 4 '13 at 18:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Looks like you have you added some Qt related PPA's, and have installed newer Qt libraries which lead to dependency conflict.

The easiest way would be to uninstall 4:4.8.3+dfsg-0ubuntu4~quantal1~test4 Qt packages, remove 3rd party Qt PPA's, and try again.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.