Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was setting up a kiosk per this tutorial http://www.instructables.com/id/Setting-Up-Ubuntu-as-a-Kiosk-Web-Appliance/?ALLSTEPS

I have hit a problem with the kiosk.desktop file since it is not autorunning when i login to the kiosk account. I cannot figure out why. I have spent extensive hours googling the problem from several angles and am at a point where I can't get it without help.

my kiosk.desktop file is located at /usr/share/xsessions/kiosk.desktop and it reads as follows.

[Desktop Entry]
Encoding=UTF-8
Name=Kiosk Mode
Comment=Chromium Kiosk Mode
Exec=/usr/share/xsessions/chromeKiosk.sh
Type=Application

do I have any typos or something that is wrong in that regard? I have also included my bash file to see if the problem is there not with the .desktop file.

#!/bin/bash
xscreensaver -nosplash &
width=`xrandr | grep \* | head -n1 | cut -d' ' -f4 | cut -d'x' -f1` 
height=`xrandr | grep \* | head -n1 | cut -d' ' -f4 | cut -d'x' -f2` 

echo $width,$height 

cat ~/.config/chromium/Default/Preferences | perl -pe     "s/\"work_area_bottom.*/\"work_area_bottom\": $height,/" > /tmp/tmp.$$ 
cp /tmp/tmp.$$ ~/.config/chromium/Default/Preferences 
cat ~/.config/chromium/Default/Preferences | perl -pe "s/\"bottom.*/\"bottom\":     $height,/" > /tmp/tmp.$$ 
cp /tmp/tmp.$$ ~/.config/chromium/Default/Preferences 
cat ~/.config/chromium/Default/Preferences | perl -pe     "s/\"work_area_right.*/\"work_area_right\": $width,/" > /tmp/tmp.$$ 
cp /tmp/tmp.$$ ~/.config/chromium/Default/Preferences 
cat ~/.config/chromium/Default/Preferences | perl -pe "s/\"right.*/\"right\": $width,/"     > /tmp/tmp.$$ 
mv /tmp/tmp.$$ ~/.config/chromium/Default/Preferences
while true; do chromium-browser %u --kiosk --start-maximized; sleep 5s; done
share|improve this question
    
I navigated to the kiosk.desktop file in my file browser and executed it. It worked to launch a chrome kiosk but didn't autorun like it was supposed to. I set a link to this in the startup applications that runs it on startup. THIS IS A HACKED SOLUTION AND NOT WHAT I WAS LOOKING FOR. –  skids89 Apr 4 '13 at 18:02

1 Answer 1

probably your script does not have execute permissions

chmod 755 /usr/share/xsessions/chromeKiosk.sh
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.