Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a new Ubuntu user. I just installed 12.04. To get Chrome on the Launcher, I clicked the BFB and searched for Chrome, then dragged that icon to the Launcher. However, when I run Chrome, it creates a second icon for the running chrome. Creating a second window creates a second triangle under the second Chrome icon, with the first icon not doing anything. It is also apparently not locked to the launcher and I can't remove it. Does anybody know how to remove the first icon? I have locked the second icon to the launcher and it seems to be working fine, but I don't want two icons.

share|improve this question

2 Answers 2

I periodically run into this problem and variants of it, most recently on Ubuntu 14.04.

Here's what has worked for me in these cases:

  1. Close all Chrome windows (and choose Exit from the Chrome indicator menu, if you have one).
  2. Right click on all Chrome icons in the launcher and choose Unlock from Launcher.
  3. Open the Files application.
    1. Choose Location from the Go menu (or press Ctrl-L).
    2. Type .local/share/applications into the text field and press Enter.
    3. You should see a number of files whose names contain "chrome" (or "chromium" if you're using Chromium instead of Google Chrome. Send these files to the Trash (but leave any other files in this folder alone).
  4. (You might have to log out and log back in at this point, but I don't think this is always necessary.)
  5. Open the Dash and type chrome. You should see only 1 entry.
  6. Launch Chrome and lock to the launcher (by right clicking on the icon and choosing Lock to Launcher or by dragging the icon out to the right of the launcher and then back in at a different location).
  7. Close the Chrome window, and then use the launcher icon to reopen it. It should open normally and you should not see a 2nd icon appear.
share|improve this answer

I think this is a bug.

Try the following:

unity --reset-icons

The above command will reset the icons the way they were when you first installed Ubuntu.

or type:

gksu gedit /usr/share/applications/nautilus-home.desktop

and remove the following line:

OnlyShowIn=GNOME;Unity;

I hope this helps.

share|improve this answer
1  
Good idea, but.. didn't work. Found this while Googling... –  JamesTheAwesomeDude Jul 4 '13 at 2:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.