Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a Mac to do remote desktop into an Ubuntu machine; there are two problems:

  1. I have to login as root to ignore the keyring notification that would otherwise pop up on the Ubuntu desktop when I try to connect from the Mac. This one I can get around by logging in as root, but I can't figure out how to auto login, as Ubuntu makes that difficult (I know it's not safe, etc etc, but I'm doing testing on an internal network...I don't care).

  2. I have to login. Big problem. Unless I physically login on the box, I can't access remote desktop. I can't even see it in the Mac "Finder" list until I login; does anybody know of a workaround?

share|improve this question

migrated from stackoverflow.com Feb 23 '11 at 17:27

This question came from our site for professional and enthusiast programmers.

closed as too localized by fossfreedom Feb 21 '12 at 22:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is pamusb out of the question? –  Allan Feb 23 '11 at 20:39
    
Can you explain what you mean by "keyring notification"? And autologin (as non-root, obviously) is an option in the Users & Groups system configuration dialog. –  JanC Feb 23 '11 at 22:11
    
Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyway or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reason(s) why you want it open. Regards –  fossfreedom Feb 21 '12 at 22:00