Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a fresh install of Ubuntu removing Windows and every data from the drive. I chose the option to encrypt my disk pre-boot.

When I boot Ubuntu out of GRUB, I get a black screen for a second or two but then the screen where I have to enter my passphrase shows up and everything works fine.

However, my laptop isn't supposed to always boot into GRUB (Ubuntu being the only OS). When I boot the machine without GRUB, all I get is a black screen that doesn't initialize even after waiting for a couple of minutes.

It is possible to press Ctrl+Alt+T on that black screen, and it yields some kind of boot console saying

Enter passphrase: **error: unexpectedly disconnected from boot status daemon
cryptsetup: cryptsetup failed, bad password or options?
Unlocking the disk /dev/disk/by-uuid... (sda5_crypt)
Enter passphrase:

So I can now put in my passphrase into that white on black console screen and Ubuntu will boot normally (without the Ubuntu splash screen though). I furthermore noticed that I am able to enter the password "blindly" (i.e. without bringing up the console first), hit enter and Ubuntu will boot as well.

I did already try the boot-repair utility and reinstalling Ubuntu. I would very much like to see the usual "enter passphrase" screen instead of having to bring the boot console up first, but I'd also be glad when I could manage the machine to automatically boot into GRUB, wait 0-1 seconds, automatically choose Ubuntu and then get to that passphrase entry screen.

Setting the GRUB_HIDDEN_TIMEOUT like suggested in this thread didn't work for me, though. It still yields the same result as if I was booting the machine without GRUB.

share|improve this question
    
Same problem on Ubuntu 2013.04 –  Nicolas Raoul May 14 '13 at 6:32

2 Answers 2

It's a video card initialization bug (as in there's not a simple answer or it wouldn't be a bug). Giving it the three fingered salute a couple of times gets it visible without pressing any keys during the final boot process, or you can use an up arrow while the screen is black to get the prompt (followed by backspace to not be entering ^something).

Anyway, I don't expect the bounty, but this is a known issue (bug) that has been around for some time.

share|improve this answer
    
By "three fingered salute" you mean Ctrl+Alt+T? I didn't quite understand that line due to the "without pressing any keys" confusing me... Anyway, thank you very much for the answer, at least now I know there's nothing I can do about it, haha. –  Harti Apr 15 '13 at 12:32
    
Ah, and when you said it's a bug - is there a chance to get rid of it by installing Ubuntu another time or does it simply apply for certain machines? –  Harti Apr 15 '13 at 12:41
1  
Ctl+Alt+Delete (reboot). And it only applies to certain graphics cards. I've had this bug for a while (FDE + Nvidia blob in my case. It seems to change in how it evidences between blob drivers and noveau for me).Re-installation does not remove the issue. –  hbdgaf Apr 15 '13 at 14:23
up vote 0 down vote accepted

Upgrading to Ubuntu 13.04 resolved the issue (for me at least).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.