Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I open port 22 for Sparkleshare?

Every time I run dazzle create name_of_the_project (Sparkleshare) it gives the address but does no show the port as it should be.

Example: it shows: ssh://storage@105.236.222.41: After (:) it should says 22, which is the port.

Why it is not showing the port? and how can I open the port in my Ubuntu 12.04 LTS?

share|improve this question

2 Answers 2

First check about availability of that port

sudo netstat -ntlup

the above command will list all the active listening ports.If the port number which you want is not active then you can open it.

lsof -i :8888

The above command will list the program If any application using that port 8888.If no process using that port then you can use that port . If any process using that port then you have to kill the process then only the port can be used.

to kill a process you can use command like

kill <pid>

hope that helps.

share|improve this answer

Check your firewall, you may be blocking it from firewall.

First try to disable the firewall (sudo ufw disable) & check. If it works then you can allow it from firewall

Try this, sudo ufw allow 22

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.