Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm attempting to backport Clang 3.2 to Quantal from Raring. Thinking this would be a relatively painless process, I ran the following command:

backportpackage -s raring -d quantal -u ppa:george-edison55/clang3.2-backports clang

The package was uploaded to the PPA without any errors and built without any errors as well. Unfortunately, it cannot be installed because the debian/control file contains the following dependencies:

Depends: ... libgcc-4.7-dev, libobjc-4.7-dev ...

Those packages do not exist in Quantal. The contents of those packages is contained in the gcc-4.7 Install gcc-4.7 and gobjc-4.7 Install gobjc-4.7 packages instead. My problem is that I have no idea how to make the change before uploading the package to my PPA.

I tried instructing backportpackage not to upload to my PPA and dump the files in /tmp/clang3.2 where I edited them. However, attempting to upload the package simply results in the original .tar.gz being downloaded again and overwriting my changes.

What is the proper way of doing this?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.