Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu on my lappy alongside with Windows7 on DriveE (windows is in DriveC). when installing ubuntu it didn't ask any thing it ask only whether you want to install alongside with windows. I selected that option. there was message that installation was successful. After restarting it directly boots to windows it's not asking to select os and driveE which i have installed ubuntu is not visible.

please give solution to my problem

share|improve this question
1  
How did you installed ubuntu? are you using wubi.exe? or you are booting using a usb /cd –  Web-E Apr 3 '13 at 5:53
    
I have done installation through CD –  Murali D Apr 3 '13 at 8:20

1 Answer 1

The problem is with the Linux bootloader (GRUB). Looks like it isn't installed correctly.

To re install GRUB you will need the live disk once again.

There are two ways,

Manual Method,

You can follow the great answer here - How can I repair grub? (How to get Ubuntu back after installing Windows?)

Though question is different, it is applicable for your case. In your case it should be sda not sdb as mentioned in answer step3.

Also Step 7 is must in this case.

Easier way,

You can use live disk & boot-repair tool to perform a Recommended Repair.

Instruction are here - https://help.ubuntu.com/community/Boot-Repair

At the end, it will generate a URL, please take a note of that URL. If after recommended repair, it doesn't load GRUB, please attach the URL in this question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.