Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am exploring ways to use U1 as a backup tool (indeed, it isn't, but I signed up thinking it was, so now I'm trying to make the best of it :-)) One way I'm contemplating is excluding backup files from being handled by the U1 syncdaemon. Unfortunately, it seems that such exclusion works only one way, namely from the local host to the U1 cloud, and not the other way around.

For instance:

  • in "/etc/xdg/ubuntuone/syncdaemon.conf" I expanded "ignore.default" with the line "\Aduplicity-.*\Z" to exclude duplicity backup files from being synced.
  • When, by way of test, I create a file named "duplicity-blabla" in the synced local folder, the file is not uploaded to the U1 cloud folder, as I would expect.
  • However, when I upload the same file to the U1 cloud folder via the U1 web interface or through duplicity (via the command line), the file is synced to the local folder. In Nautilus, the automatically downloaded file gets the green 'synced'-checkmark. Yet, it is possible to delete the downloaded files from the local folder without deleting the remote copy from the U1 cloud.

Why does the syncdaemon download excluded files from the U1 cloud, and is there a way of stopping it from doing so?

share|improve this question
You should probably not edit /etc/xdg/ubuntuone/syncdaemon.conf but instead create a ~/.config/ubuntuone/syncdaemon.conf with only the sections/values you wish to change. – dobey Apr 2 '13 at 18:50

I think the best solution here is to have duplicity back up to a U1 volume that isn't synced to a local folder at all:

duplicity full /folder/to/back/up u1://u1/backups/backup-name

After the initial backup finishes, open u1 and make sure that "sync locally" is not checked for /backups/backup-name. The local folder is not necessary for duplicity's U1 backend.

share|improve this answer
Thanks for the tip. This is actually another option I am exploring, which boils down to 'unsubscribing' from the backup folder with u1sdtool. You don't happen to know why duplicity – user146307 Apr 2 '13 at 20:52
(whoops, I accidentally entered my previous comment) point: I´m unsure as to how robust the alternative is, since I do not completely understand syncdaemon's and duplicity's behavior (and I don't want them to accidentally hurt my precious backups by unanticipated actions). Any U1 cloud folder created by duplicity, for instance, is automatically synced to the local host, even when I left "automatically sync all new cloud folders to this computer" in the U1 GUI unchecked. It scares me that I can't properly predict actions by my backup tools. – user146307 Apr 2 '13 at 21:04
I'm surprised that you get the backup folders synced by default. When I run the duplicity command, it doesn't get synced and u1sdtool --list-folders shows subscribed=False just like I would expect. – cscarney Apr 2 '13 at 22:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.