Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Toshiba laptop that was running Windows 8. I installed Ubuntu 12.10 and deleted Windows 8 in the install. Ubuntu worked fine until I shut the PC down. When I tried to start it again it would just go to a black screen. If I take the battery out of the PC and put it back in and turn the PC on Ubuntu will work.

How do I fix this problem?

share|improve this question
add comment

1 Answer

I have a similar problem with one HP Laptop (Pavilion dv6) for more then 2 years look here. What I have discovered so far:

1) Buying another battery doesn't fix the problem,
2) Taking out the battery with the cable connected also doesn't fix it,
3) I have to be careful not to disconnect the power cable when the laptop is shutting down,
4) I have to be super careful not to connect the power cable when the laptop is booting up (but connecting it after the boot seems ok),
5) I got more successful boots with the power cable disconnected,
6) I tried some grub acpi configurations without success.

So I've settled. The two most important steps seems to be the numbers "3" and "4".

Best regards.

share|improve this answer
    
I was going to suggest something along the line of number 6. –  wojox Apr 2 '13 at 12:27
    
Please update initramfs and the tell-me if you keep having that problem. Use "sudo update-initramfs -u" –  Celso Apr 13 '13 at 1:40
    
I have found some information here wiki.ubuntu.com/Initramfs .I will be able to test this on Wednesday, but I am thinking that I already have tested three brand new installations (11.04, 11.10, 12.04), and I can't see why sudo update-initramfs -u should work. Any tips? –  desgua Apr 14 '13 at 1:19
    
I've just updated the initramfs let's hope for the best ;-) –  desgua Apr 22 '13 at 11:05
    
One week has passed without this issue. Let's keep observing. –  desgua Apr 29 '13 at 12:37
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.