Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using Ubuntu 12.04, current kernel is 3.5.0.02-generic.

I have downloaded and installed 2 days ago Intel Linux Graphics Installer deb file suitable for Mobile Intel 965 Express Chipset Family. After one day, I can not boot in ubuntu, I have a black login screen. This should have generated my problems I suspect.

I have tried the following options in grub menu:

  1. removing quiet and adding nomodeset options: stuck in the spash screen
  2. remove splash & quiet: tty1
  3. remove quiet: black screen
  4. remove splash & quiet, add nomodeset: tty1
  5. remove splash: black screen
  6. replase splash with no splash: black screen
  7. start old kernel (3.0.2.37): nothing

I have also tried apt-get -check, -update, -upgrde, -purge, -autoremove,... All no changes.

In recovery mode, I tried dpkg which resulted in no changes and start in graphics safe mode which stays in terminal.

Whenever I try to startx from terminal, I receive message

X cannot stat /etc/X11/X

Is there any way to remove packages installed on 30th and 31/3/2013?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The solution to my problem was the following in 3 steps:

  1. reinstall xserver:

sudo apt-get remove --purge xserver-xorg

sudo apt-get install xserver-xorg

sudo dpkg-reconfigure xserver-xorg

2... then run from recovery mode dpkg, 5 obsolete packages removed: x11-xfs-utils, libfs6, x11-apps, x11-session-utils, xinit.

3... I could login normally in graphics environment only as guest, so I had to login in tty and sudo rm ~/.Xauthority

Hope it helps someone else :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.