Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new in using Ubuntu, I just installed ubuntu 12.10 and everytime I start up the pc, a message tell me that

the drive /dev/mapper/ubuntu-swap_1 is not ready yet or not present

.

This is my current situation:

sudo blkid
/dev/sda1: UUID="fa675e68-de82-4257-8960-bb312d08e113" TYPE="ext2" 
/dev/sda5: UUID="NLQ7rm-qbYa-QS4y-If3b-nLaY-FHZq-Dklhr8" TYPE="LVM2_member" 
/dev/mapper/ubuntu-root: UUID="bf5875d5-5cdd-4b08-a16e-168f75e535e9" TYPE="ext4" 
/dev/mapper/cryptswap1: UUID="1acc7002-dc75-452d-b46f-034c03c00f5e" TYPE="swap" 

in the etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/ubuntu-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=fa675e68-de82-4257-8960-bb312d08e113 /boot           ext2    defaults        0       2
/dev/mapper/ubuntu-swap_1 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

in the forum there are suggestions to change the name with uuid,but in my case in fstab there are 2 swap.

should I change it anyway?

share|improve this question
    
Accept the answer If its helped you. –  raaz Feb 4 at 5:19
add comment

2 Answers

I think you are talking about the last line of your /etc/fstab file , I mean

/dev/mapper/cryptswap1 none swap sw 0 0

So If you observe it one more time , the keyword is cryptswap1 nothing but at the time of installing Ubuntu you may have selected Encrypt your home directory option that's why only it came up into the action else it won't. That partition will mount everytime at the booting and that will help you in the Home directory encryption . No problem with that.

If you are not using encryption now then you can remove it by deleting that specific partition .

If you want to find out status of the partition then you do it with

 sudo cryptsetup status cryptswap1

Hope that helps.

share|improve this answer
1  
Thanks.this explain to me what cryptswap1 means. –  ofe Apr 3 '13 at 4:27
add comment

This is little different, as per blkid command you mentioned you have one swap with named "/dev/mapper/cryptswap1" but in /etc/fstab, you have another swap "/dev/mapper/ubuntu-swap_1" (Before doing anything please check how many files /dev/mapper directory consist, by default it show you only ubuntu-root and cryptswap1)

I have a suggestion for you, run

sudo swapon -s

and check how many swap is working in your system. If it show you output only "/dev/mapper/cryptswap1", then you can remove that /etc/fstab "/dev/mapper/ubuntu-swap_1" entry from there.

And if the output of swapon -s is like

Filename Type Size Used Priority

/dev/mapper/cryptswap1 partition 4071420 2568 -1

/dev/mapper/ubuntu-swap_1 partition 4071420 2568 -1

Then you have to turn off ubuntu-swap_1 swap partition first and then remove entry from /etc/fstab file

sudo swapoff /dev/mapper/ubuntu-swap_1

Restart your system and ubuntu-swap_1 will gone. Might it helpful for you.

share|improve this answer
    
in my dev/mapper i have ubuntu-root criptswap1 and ubuntu-swap_1.when running swapon -s It does not return any swap available.If running sudo cryptsetup the criptswap is active. Should I create manually the ubuntu-swap_1? –  ofe Apr 3 '13 at 4:40
    
you already have one swap for Ubuntu , why you need one more again ? –  raaz Apr 3 '13 at 7:26
    
theI would like to have one swap. main problem is that at ubuntu start up i got the message reported on top of my description, that means that it can create a swap , if i understand correctly.in addition if i run the sudo swapon -s command, it return no swap available. –  ofe Apr 4 '13 at 20:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.