Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded the 12.10 server ISO and used Linux Live USB to create a bootable stick. I used this stick to go through the install process. The target is a Lenova Q190. The install process seemed to go fine and it got to the point where it said to remove the media and restart. When I did so the Q190 reported:

Error 1962: No operating system found. Press any key to restart the boot process.

The only thing I could think of was that it was the wrong ISO. I had used the AMD-64 and the Q190 has dual Celerons so I thought maybe I should be using the x86 image. I made a USB stick with that ISO but that one won't even boot on the Q190 so now I'm unsure what try next. It seems to me that GRUB isn't being executed at all. I don't know if it wasn't installed into the boot sector or if it was installed incorrectly. Any ideas?

*recent activity: I created a 12.4 CD and used a USB driver to boot off which worked well. I wanted to remove any fogginess on what the Linux Live USB stick might be doing and move to the older release to see what difference that made (answer: none).

It appears that grub is quite sure it is being installed on the MBR of /dev/sda but still the same result occurs. No operating system found.

share|improve this question
add comment

1 Answer

If you even managed to boot the installer and get through it then it's worked. You may have neglected to install the boot loader to the disk you are trying to boot from.

Go into the BIOS and reconfigure your hard disk drives so that a different one is the boot drive. If you only have one hard disk then you need to rerun the installer and make sure you are installing GRUB to its MBR if only running linux or the first partition if you have windows there too. You may also need to flag the device as a boot disk using either Windows, Ubuntu LIVE or Gparted.

share|improve this answer
    
So there is only one drive in this machine: /dev/sda. I went into the expert installation mode so I could see what the GRUB2 installer was doing and I specified that it should install on the MBR of /dev/sda. 12.x Ubuntu server is the only thing on this machine. –  cyoung Apr 3 '13 at 19:14
    
Found the problem. There was an option in the Q190's BIOS labeled: Secure Boot. When I changed it from enabled to disabled then Ubuntu booted. The description on the BIOS page said that it prevents unauthorized operating systems from running. Not sure what the utility of that is. –  cyoung Apr 4 '13 at 0:23
    
Excellent I didn't even think to mention the new UEFI stuff. It's an Intel/MS joint implementation of EFI to replace the legacy BIOS, however they have decided to lock out other OS's on certain machines. –  Adam Heathcote Apr 4 '13 at 0:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.