Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Linux and have recently set up a dual boot with Windows 7 on my Lenovo W530 (8gb RAM). During the partitioning phase of setting up my dual boot I noticed there was a 8gb partition set aside for Hibernation. Apparently this is a regular situation faced by those wishing to partition a SSD.

Anyway, the installation of Ubuntu 12.04 64bit went ahead and everything had been relatively smooth over the last few days whilst I downloaded and installed the software I required. I must admit as a noob, I felt I was copying and pasting a lot of terminal commands that might have altered the internal dynamics of the computer in ways I could not comprehend. However, this process was mostly successful.

After setting up most of the software I turned my attention to the hibernation function, as I thought it would be a waste of 8gb on my SSD if it was not utilised on Ubuntu. After reading the forums, I found that the function for hibernate had been hidden due to instability issues. I pressed ahead and followed the instructions to reenable it. This was successful. However, I noticed that on shutdown or restart, the computer would hang on a black screen in the final stages of the shutdown process. It required me to long press the power button to turn off the machine.

This morning I tried to boot the computer and found that the computer now hangs on a black screen after selecting Ubuntu in GRUB. Long pressing the power button loads the Ubuntu shutting down screen (loading dot animation), but sometimes this also leads to another black screen.

After this I booted the machine and selected the recovery menu, and after trying to boot it as a 'regular' session, the machine does not recognise my login (or maybe I am mistaken??). My first attempt at selecting the recovery menu showed a message: ata_id [878]:hdio_get_identity failed for '/dev/sbd': invalid. Although the problem persists, this message is not shown anymore.

I tried Boot Repair however this also failed to resolve the issue. FYI the message after completing Boot Repair was: http://paste2.org/p/3482165

Feeling very lost right now! Please help!

share|improve this question
Don't hard power off. That's asking for trouble. See How to safely reboot a linux OS. Also check your system log cat /var/log/syslog | grep 'PM:' for hibernation errors or review /var/log/pm-suspend.log –  bcbc Apr 3 '13 at 5:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.