Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have done a fair amount of research, and started of by disabling the secure booting UEFI settings as well as the Intel Smart boot. I partitioned the drive accordingly and when I restarted the computer it booted straight to ubuntu (which was to be expected) and after a boot-repair grub2 was working fine and showed the options for Windows 8. However, after selecting the Win8 option, my machine just hangs up at the loading screen with Sager logo. I have tried multiple resolves to no avail.

The Complete Log URL is:http://paste.ubuntu.com/5686995/

Update: I removed my second efi partition and windows is still stuck. I have tried bcdrrepair and chkdsk. I tried doing a repair with windows disk but it didnt work. I edited the grub file and manually put in a custom entry with a chainloader that should work and still no progress. When I boot it goes straight to windows RE. I check the windows syslog and get a message: a patch is preventing the system from starting up. I also tried a different bootloader suggest by a comment and the same problem occurs.

I have a 750gb mechanical drive (SDA1) and a 256 msata (boot)

share|improve this question
    
Your log is incomplete. Please indicate your complete Boot-Info ( help.ubuntu.com/community/Boot-Info ) –  LovinBuntu Apr 2 '13 at 19:54

2 Answers 2

You haven't messed anything up with the partitions, it's just that Grub has trouble chainloading Windows under EFI. Try to get to your Windows OS from the laptop boot menu, for Sager I think you press F12 when booting.

share|improve this answer
    
I messed around with it a little bit and now it is getting past that sager logo, but when it gets to windows it goes straight to the whole Automatic Repair screen which just wants me to reformat my disk. Can't get into the actual windows environment or do much of anything... Any thought as to how I might fix that? –  user2233735 Apr 5 '13 at 13:08
    
Try to follow up on this article on how to locate the automatic repair log file; if you know where it is you can get to it from an Ubuntu session too, and you can either look for clues in it or post it here or in pastebin, so others can look into it. –  Mike C. Apr 5 '13 at 18:35
    
Oh I can see now how you messed with the partitions, you have two EFI marked partitions reported by parted -l, sdb2 and sdb5, can you look into it? Perhaps you should mark sdb5 as something else, not EFI. –  Mike C. Apr 5 '13 at 18:49
    
Thanks!! I am hoping that's it.. I will check tonight. What do you suggest I mark it as? –  user2233735 Apr 5 '13 at 20:30
    
With gparted I would remove all flags, especially the boot flag, or with gdisk I would change the partition type code to 0700 - Microsoft basic data, since it is formatted FAT32. –  Mike C. Apr 6 '13 at 1:09

Try installing rEFInd in Linux. Using the Debian package should set everything up to work correctly with no further effort, although you might want to remove some entries later. With any luck, rEFInd will boot either Windows or Linux with no problems.

share|improve this answer
    
I have no Idea what the problem is but I installed it and the menu came up when i booted my computer but when i booted windows it went straight to windows recovery thing which still doesnt let me boot into windows. I can access my windows partition from ubuntu and windows was working fine before the install so i dont think i corrupted anything.. The syslog from the Windows Diagnosis says: A patch is preventing the system from starting. –  user2233735 Apr 6 '13 at 21:29
    
I'm not very familiar with Windows error messages, but that sounds as if there might be a pending software update for Windows that's gone wrong. I recommend either running a Windows recovery utility (but be careful, since they like to trash everything and restore the hard disk to a Windows-only configuration) or call Microsoft for help. –  Rod Smith Apr 7 '13 at 17:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.