Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The are several guides online (including a few on the ubuntu website) that follow the general pattern of instructions found in this one.

I assume that at some point, this worked.

However, on an Intel iMac 5.1 with Ubuntu 12.10, it does not work. Each command executes successfully, but the result is a drive that will not boot.

Holding Alt during the boot, as the guide suggests, brings up a menu that does not include the USB drive.

Alternately, booting into rEFIt or rEFInd does in fact show the device, but refuses to boot, producing the error message:

Error: Not found from LocateDevicePath
(x 9 times)

Error: Load Error while (re)opening our installation volume

The firmware refused to boot from the selected volume. Note that external hard drives are not well-supported by Apple´s firmware for legacy OS booting

Perhaps the guide needs to be updated? I'm not sure what to try differently here.

Edit: This is apparently not limited to 12.10. I just had the same issue occur with 12.04.2.

Edit: I get the same issue ("refused to boot") following these instructions:

share|improve this question

DO NOT USE A STANDARD LIVE USB INSTALL WITH MAC it won't work. Caps left for emphases.

You can find some dated instructions here

First you have a couple of real things that your doing very wrong for a mac install. You should use only the prescribed mac installer disk for your chosen distro. Sometimes you can find mactel ISOs but more often then not you can just use the 64bit desktop installer and sudo add-apt-repository ppa:mactel-support before you actually install. Don't forget to add it after installing too.

Second, linux does not work well on macs in EFI mode. That's not to say it doesn't work at all, but it doesn't work well. So make sure you reach the installer via refit. Make damn sure you only resize your mac partition with Disk Utility and not druid. Finally make sure your MBR and GUID partition tables are in sync (this can be done via refit).

Lastly, it seems your having the most dificult making the bootable flash disk so... take a look at these instructions Make sure you use the standard desktop ISO or better yet the mactel ISO.

Here is a download location:
The downloads page

share|improve this answer
I'm using a 32-bit mac. You're telling me I'm supposed to use the 64-bit ISO? – Justin Myles Holmes Apr 1 '13 at 23:54
Please check your CPu specs. What I can find is that the iMac 5.1 was the first 64bit iMac. If that is true then yes use the 64 bit kernel/installer. If not use the 32bit one but rest remains accurate. – coteyr Apr 2 '13 at 0:00
Note, that the version of OSX installed back then would have been 32bit. But the hardware is still 64bit. (I think) – coteyr Apr 2 '13 at 0:04
coteyr: You are in fact correct. Nevertheless, the 64-bit iso gives me the exact same issue. :-( – Justin Myles Holmes Apr 2 '13 at 1:03
Refit (and also Refind) gives me the same error message as before. – Justin Myles Holmes Apr 2 '13 at 2:11

So it took me about 7 hours to figure out, but i finally got Ubuntu to run on an old MacBook running 10.4.11

  1. Download and install refit
  2. Download Ubuntu 32 bit (the macbook only has a gig of ram, so 64 bit isn't recommended)
  3. Convert the ubuntu iso to img via:

    hdiutil convert -format UDRW -o ~/Desktop/ubuntu.img
  4. Open disk utility and drag the img file to the left pane (your hard drive should be listed, etc). Click burn and burn the img file to a dvd (thankfully my macbook had a dvd burner)

  5. Reboot and refit should pop up. Click the linux icon and enjoy

Here are some links that helped me out:

Video for refit install ->

Converting ISO to IMG ->

share|improve this answer
Hello @jellz77. That looks like a mighty fine answer and a lot of work went into it. Given the date of this question and that you seem to have resolved this with different hardware and a different version of Ubuntu, I'd recommend that you write your own question and then answer your own question and accept that answer. (That's not just allowed here, it's encouraged.) I'd hate to see your work be missed by others in your shoes and it would make a fine question/answer that you can add to the community. Let me know if you do - I'll add my vote to the pile. :D – KGIII Nov 11 '15 at 8:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.