Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I was setting up my bluetooth headset to my Ubuntu 12.10 desktop just for kicks, and I made a mistake. In Sound Settings under the Output tab, I changed the "Mode:" to "off". The headset has now disappeared from the sound settings entirely, however it is still connected to bluetooth. No change even after I disconnect and reconnect the headset (forget device and set up again).

Is there maybe a config file where I can adjust a line to make it revert to default?

Similar to this, link, but his solution of:

$ pactl list cards short
0   alsa_card.pci-0000_01_00.1  module-alsa-card.c
1   alsa_card.pci-0000_00_14.2  module-alsa-card.c
4   bluez_card.0C_14_20_28_4E_17    module-bluetooth-device.c

and running the command:

$ pactl set-card-profile bluez_card.0C_14_20_28_4E_17 a2dp

gave me the result:

Failure: No such entity

Oh, and it was really loud (while it was working, which is why I was messing with the settings to begin with) even with 1% volume. Not sure if that can be easily fixed. What do you think?

Thanks in advance.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

In a standard Bluetooth setup we can change the profile of a Bluetooth audio device from the Hardware tab in Sound settings:

enter image description here

Alternatively we can use the command line to switch profiles:

pactl set-card-profile <name or index of card> <profile>

After we had chosen the profile to "Off" it will not be shown in the Output tab as a valid audio output sink. As soon as we had enabled another profile, e.g. "a2dp", or "hsp" it comes back as a selectable device for Output.

Troubleshooting:

If this is not the case with your headset there may be an issue with the device's firmware. You may try the following steps:

  • reset pulseaudio with the following command:

    pulseaudio -k
    
  • Delete ~/.pulse:
    All user setting which may interfere here are stored in ~/.pulse. It is safe to delete this directory if you had not used it for custom settings files. To be able to restore the directory use the following rather than deleting:

    mv ~/.pulse ~/.pulse.000
    
  • Re-pair your headset:
    Remove your device from the list of known devices, and then pair it again as a new device.

  • Use pavucontrol Install pavucontrol rather than Sound Settings for adjusting sound hardware settings.
share|improve this answer
    
Thank you. My sound settings page did not include a "Hardware" tab. I reset pulseaudio, renamed the .pulse file, and repaired my headset. That combination, followed by a reboot, worked very well. :) –  jtaptriot Apr 13 '13 at 6:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.