Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I know I can remove visited pages from the history via History→Show all History, and simply mark the unwanted entries plus hit the Delete key. But this seems not to remove the URLs I've typed into the address bar when calling up those pages. So they are still used to predict the URLs I want to type in later. Especially with sites one heavily frequents (like here on the StackExchange network), this clutters up the list of suggested URLs.

Is there any way to remove the "typed URLs" from the browser history completely? Preferable with some easy clicks for the end-user -- but I wouldn't mind doing so via command-line if necessary (e.g. modifying Firefox's sqlite databases directly).

Edit: Thanks to Dan's answer a part of my issue is explained -- and I found out I missed to fully describe it. Until reading Dan's explanations, I didn't see some of the details.

So let's say I've visited http://readwrite.com/somearticle and http://readwrite.com/otherarticle. And of course a lot of other pages having an "r" somewhere in their URL. Now, on an empty urlbar, I type an "r". Immediately, auto-complete fills that up with "readwrite.com" (not one of the full URLs), and the drop-down shows a bunch of other pages (but none from readwrite.com).

  • Dan's first method doesn't work, as the auto-completed string is not contained in the dropdown
  • Dan's second suggestion (switching auto-complete off altogether) is no option for me, I just want to get rid of some specific "suggestions"
  • I have no matching bookmark (to be more specific: none for readwrite.com)

So how to get rid of that "readwrite.com" suggestion? I've checked the entire history and made sure there's no entry left for it. I've also checked my bookmarks, no traces there either.

share|improve this question

5 Answers 5

When you've typed an URL into the address bar, and the autocomplete popup is visible, highlight an URL in the list and press Delete. That will stop that URL being suggested again for any query. If there are many similar URLs you want to get rid of, you might need to backspace the last character and type it again to refresh the list.

Note: This doesn't work on bookmarked URLs. Hitting Delete removes them from the list while it's open, but the bookmark will be suggested again next time you type a similar URL. If that causes you a problem: on the Options dialog, on the Privacy tab, there's an option to make it only suggest from history, not bookmarks.

There's also another kind of autocomplete, where a domain name appears inline in the address bar itself (not in the autocomplete list) as you type. It only completes the domain name, not the whole URL, so it doesn't cause the "too many completions for stackoverflow.com" problem you describe.

The suggestions come from the same list, so if you delete all the autocomplete items for a domain and you don't have any bookmarks for that domain, it won't suggest that domain inline either. This can be quite tricky to arrange, as in your example, if you type "rea" and it completes readwrite.com but the list is full of pages about "reanimation". In that case, you need to let it complete readwrite.com by pressing End (not Enter), and then backspace the last character to refresh the list. Then only the readwrite.com entries will show in the list, and you can delete them in the same way. Again, if there are lots of entries, you might need to backspace the m to refresh the list.

You can disable just the inline-autocomplete feature by going to about:config and setting browser.urlbar.autoFill to false. That setting doesn't affect the drop-down list of suggestions, only the inline suggestion.

share|improve this answer
    
Thanks, Dan! But that seems not always to work. I have e.g. "readwrite.com" somewhere in the history. As soon as I start typing "r", that's the suggested URL. But it's not contained in the drop-down list. So how to delete it, if I cannot select it? I tried to completely mark it in the address bar, and hit 'delete' key then. But that doesn't seem to remove it: Next time I start typing 'r' (even in a different tab), it's displayed again. If I simply hit "enter" (so the page is open), it's no longer suggested then (even after closing the tab, ugh!) –  Izzy Apr 1 '13 at 19:46
    
I see. I added more information to my answer. –  Dan Hulme Apr 1 '13 at 22:59
    
Thanks a lot, that describes about what I just experienced. I still wonder, as I had no "readwrite.com" bookmark (but of course visited one specific page there), how to get rid of all entries for that domain without completely disabling auto-complete. I thought opening the suggestion and then deleting the urlbar content did it; but when I did so for the second "r" domain, readwrite.com was back. So I might need to update my question to better explain the entire dilemma... +1 meanwhile :) –  Izzy Apr 1 '13 at 23:10
    
+1 for mentioning the domain autocomplete, which is missing from the dropdown list! –  lenz Feb 23 at 11:56
    
This is how it is supposed to work. Unfortunately, Firefox is buggy (bug #932036). In fact removing the domain autocompletion does not work for me, even when pressing End and then Backspace (no dropdown ever shows up), and I have no History, Bookmark, or drop-down items from that domain. The solution by @Izzy worked (for me it was in the moz_hosts table), and the more radical solution of deleting the places.sqlite file also seems to work. –  jmiserez Jun 15 at 19:26
up vote 3 down vote accepted

As all things accessible via Firefox's default interface seemed to fail, I decided to take the "deep-dive" approach. So I installed the SQLite Manager plugin, opened the places.sqlite file from within my firefox user profile directory (Menü: Database → Connect Database), and checked the moz_places table (select it in the left pane of SQLite manager) via the search function (in the big right pane: Tab Browse and Search, there the "Search" button) for the "offending" url. The corresponding SQL-Statement (for the Execute SQL tab) would have been:

SELECT * FROM moz_places WHERE url LIKE '%readwrite.com%';

For users prefering the graphical way:

Screenshot
Screenshot of the search filter (click image to enlarge)

As it turned out, there was exactly one hit with a full URL, which did not show up when filtering the browser history/bookmarks! So I took the freedom to delete that record, and tried my urlbar again: Yeah, looks like that solved the issue! But why so difficult, Mozilla?

EDIT: Keep in mind that "operating directly at the heart" you might "kill the cat". Be careful modifying Firefox' databases directly -- or you might end up with inconsistent bookmarks or worse! Always cross-check before deleting, for example.

share|improve this answer
1  
I found that the URL came from the moz_hosts table in my case, so the query would be SELECT * FROM moz_hosts WHERE host LIKE '%readwrite.com%';. The bug report is here: bugzilla.mozilla.org/show_bug.cgi?id=932036 –  jmiserez Jun 15 at 19:07

Problem

This is a bug in Firefox, specifically bug #932036.

The answer by Dan Hulme describes how Firefox is supposed to work. Unfortunately, this does not always actually work, even when pressing End and then Backspace (no dropdown ever shows up). Even if you have no History, Bookmark, or drop-down items from that domain, the autocomplete will still suggest domains that you visited in the past.

The reason is that in some cases URLs are not removed from the places.sqlite file in your Firefox profile directory, even if you clear the complete history.

Solution

According to the bug report linked above, this means that your places.sqlite database is corrupted. The recommended approach is to delete the places.sqlite file altogether. This should prevent the bug from occurring again on your installation in the future.

  1. This will cause you to lose all your browsing history, so be careful!

  2. Quit Firefox

  3. Then, delete (or better yet move it somewhere safe) places.sqlite. The file is usually located at ~/.mozilla/firefox/<randomnumbers>.default/places.sqlite

  4. Also remove the places.sqlite-shm and places.sqlite-wal files.

Your bookmarks should still be there, but your history will be gone. The bookmarks will be restored from the latest automatic backup that Firefox made (in the bookmarkbackups folder), so very recent additions will be lost. If you are afraid of losing newly added bookmarks I suggest exporting your bookmarks beforehand.

From http://kb.mozillazine.org/Places.sqlite#Deleting:

If you suspect that the file is corrupted, deleting "places.sqlite" will delete your browsing history, and a new, empty file will be created automatically. In Firefox 3 and SeaMonkey 2.1 and above, places.sqlite will be rebuilt using the latest dated JSON file from the bookmarkbackups folder; if no JSON backup exists, bookmarks will be imported from bookmarks.html, if found.

Not recommended (see bug report)

If you want to take a risk you can also modify the places.sqlite file directly. Do note that with this approach it is likely that the bug will reoccur. That said, you can use the SQLite Manager plugin recommended by the answer by Izzy to edit the moz_places and moz_hosts table and remove the entries containing the URLs manually.

You can search for the URLs as follows (replace example.com as appropriate):

SELECT * FROM moz_places WHERE url LIKE '%example.com%';

and

SELECT * FROM moz_hosts WHERE url LIKE '%example.com%';
share|improve this answer

I had the same annoyng issue, everytime I start typing ww..... then the stored web adresses appear... not serious, but very VERY annoying. I use Firefox.

I went onto the Firefox website and looked in HELP, I finally solved this.

  • In the URL bar type : About:config (and promise to be carefull !)
  • locate : Browser.urlbar.default.behaviour (this value is probably 0)
  • double click this, so that you can modify it, and change the 0 to 33.
  • close this page Your problem should be solved, it did for me.

Thank you Firefox !

share|improve this answer
1  
Could you explain how "33" causes the right behavior? Because that seems to be 32+1 which is typed+history. –  Nattgew May 19 '14 at 19:55
    
Thanks for the explanation, @Nattgew – I was just about to ask if that shouldn't read "42" instead ;) // user283259: Still open question to me, how to calculate that number so it kicks off only those URLs I want to get rid off. My question was not about disabling auto-complete generally, but just to remove several URLs from appearing within (quoting from the question: switching auto-complete off altogether is no option for me). So does your answer fit that – and if so, how? –  Izzy May 19 '14 at 20:19

I found the solution here (dangowan's answer)

I hope it works for you

ps.: sorry my poor English :(

share|improve this answer
    
Thanks for your answer, Jacques – but I don't want to disable auto-suggest completely. My goal was just to keep some URLs from being included here. –  Izzy Feb 1 at 12:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.