Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried connecting my Toshiba laptop with Intel® Core™ i3 CPU M 330 @ 2.13GHz × 4 processor to my TV using a HDMI connector. Though I can receive images on my TV, I still get audio my laptop speakers and not my TV.

My graphics type is shown as unknown in the system settings.

Can you please help me with this?

Thank you and regards,

share|improve this question
add comment

2 Answers

If you look in the bar at the side, you may see an application named 'System Settings'. Click on this link and then under 'Hardware', click on 'Sound'. Then, try adjusting the default audio output device for your computer. In this case, it will be HDMI Audio.

share|improve this answer
add comment

You might have to update your graphics driver since HDMI is a digital signal for both audio and video. If you type

 aplay -l, 

you should see all your audio outputs. If your HDMI output is not listed, then it is probably a driver issue. If it is listed, try using aplay commands to play a file to check if it is working. This looks something similar to

aplay -D hw:0,0 /usr/share/sounds/alsa/Front_Center.wav
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.