Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've spent two days pulling my hair out trying to get Ubuntu to install correctly on a new machine I built using a Gigabyte GA-990FXA-UD3 motherboard.

Ubuntu seems to install fine, however, neither the network nor USB 3.0 drivers work out of the box. The board has a Realtek 8111E chip and to fix the network I've been trying to download and install the Realtek r8168-8.035.00 driver. I was able to get the driver on to the machine by swapping out the mouse, keyboard and USB stick from the two working USB 2.0 ports. However, it won't compile. I get the following error:

Build the module and install
make: *** /lib/modules/3.5.0-17-generic/build: No such file or directory.  Stop.

I found a thread from a failed upgrade that suggests you can solve this by using apt-get to reinstall the kernel package. So I downloaded the kernel package from a net capable laptop, moved it over to the machine on a USB drive and reinstalled it. That fixed the compile error and the driver seemed to install fine from there.

But still no dice connecting to the net after install.

I haven't even started trying to tackle the USB controller drivers. Has anyone had any success getting Ubuntu to play nice with this Mobo? What did you have to do?

share|improve this question
    
Try to use a PCIe network card until you get your hands on a working Realtek 8111E driver for your motherboard, seen it in this thread. –  Mike C. Apr 5 '13 at 19:09
1  
Please update with any solution. I am in the same boat right now. –  Nicholas Mancuso Apr 24 '13 at 1:37
    
@Nicholas Never found one. That machine is currently an oversized paperweight. I've been using a spare laptop while I try to decide what to do with it. –  Daniel Bingham Apr 29 '13 at 13:41
    
@DanielBingham, just letting you know that GUERIN's solution actually worked for me. You should check it out. –  Nicholas Mancuso May 29 '13 at 3:09
    
Daniel, could you accept GUERIN's answer? I almost dismissed his response if I had not seen Nicholas Mancuso's "HOLY SH*T" below it. @NicholasMancuso: Thank you! Good way to get my attention :) As stated below, that solved my problems with the board and 13.10. –  hknust Dec 11 '13 at 3:25

1 Answer 1

up vote 7 down vote accepted

Go to your Bios suppr or del when you turn on your computer, and when in Bios look for "network stack" and set it to "enable."

Also look for "iommu controller" and set it to "enable."

Press f10 to save and reset.

Maybe go on to the Realtek web site and download Linux drivers:

http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2

share|improve this answer
1  
HOLY SHIT this actually worked. THANK you so much. This not only fixed the USB problems but also the networking problems on my wireless PCI card! Thank you thank you! –  Nicholas Mancuso May 29 '13 at 2:58
    
Thanks buddy this saved me hours of digging around –  DevZer0 Jul 28 '13 at 8:55
    
Thanks GUERIN!!! I had the same issues that Daniel experienced (minus the build problem). Just installing the 8168 driver was not enough. Once I changed the BIOS settings everything lit up and the USB ports started working again. –  hknust Dec 11 '13 at 3:19
    
Someone queue the Hallelujah chorus! That was all it took. Incredible. Sorry it took me so long to accept, I've been using a laptop and having taken the time to go back to fiddling with the tower until now. –  Daniel Bingham Feb 9 at 21:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.