Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

This is my first time trying to compile and install anything on a linux machine. I got the latest version of via git and read the instructions which state:

2. Build and install

Exmpp uses the Autotools. Therefore the process is quite common:

$ ./configure
$ make
$ sudo make install

after type ./configure I get the error

Cannot find install-sh,, or shtool in ac-aux

Google was of little to no help. Not sure at all what I'm supposed to do. Any help would be much appreciated

share|improve this question

5 Answers 5

I got it to create the configure script using the following tools:

$ libtoolize --force
$ aclocal
$ autoheader
$ automake --force-missing --add-missing
$ autoconf
$ ./configure

I don't have all the dependencies so I can't test it right now, but this is generally how you would create a configure script from an ac file.

share|improve this answer
I'm a total noob. Can you explain what it is your doing and why the instructions in the readme file don't work? – Micah Feb 23 '11 at 6:35
The instructions in the README were probably blindly copied from somewhere else. I have to admit that I don't understand every detail of the autoconf toolchain; it's basically a collection of macros that are generated and used to create your configure script (which, in turn, sets the stage for the compilation and installation process). I never had to fine-tune these things, so I'm not an expert, but there are some fairly extensive explanations here – sebastian_k Feb 23 '11 at 7:05
I was getting undefined macro errors when executing a configure script (such as the AX_PTHREAD macro). These macros appear to be usually defined in a subfolder 'm4'. Replacing autoconf with autoreconf in sebastian_k's answer, solved this issue for me. – logion Jul 18 '14 at 11:34
Note to programmers: please stop using the automake toolchain. Please. – Qix Oct 2 at 9:41

Well, I tried sebastian_k's answer and it didn't work for me (./configure crashed midway through with an extremely weird error).

What did, however work for me was copying the instructions used in this build log I found

The short version(so you don't have to wade through it yourself is):

$ autoreconf -vif
$ ./configure --prefix=/usr/lib/erlang/lib
$ make
$ sudo make install
share|improve this answer
+1. autoreconf -i is the correct answer (the v and f are usually optional) – Nemo May 8 at 18:46

sudo apt-get install automake autoconf

its works sucessfully

share|improve this answer

I had a similar problem when i tried to ./configure a source code and got the same error as posted. Finally resolved my issues by entering the code:

sudo apt-get install autotools-dev
share|improve this answer
Error: Unable to locate package autotools. – Mauricio Scheffer Apr 20 '14 at 1:30
Same here. Error: Unable to locate package autotools. Downvoted. Sorry. – PJunior Jul 18 at 20:20

Please do the following to fix this problem,

sudo apt-get install libtool
sudo apt-get install shtool
sudo apt-get install autogen

Then do the installation

sh --prefix=prefered_install_path
make install 
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.