Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I've an Asus Z92V, I am running Ubuntu 12.10 and since I installed Ubuntu on this notebook the audio keep crackling and popping continuously. Moreover the volume bar on gnome-shell panel keep jumping from low volume to high volume continuously. This is indifferently through speakers and headphones...it's an unbearable and annoying problem!!! Since it's a common problem of Intel-HDA-audio I've found a lot of solutions and hints around web, but nothing has solved my problem...

This is the output from lspci -v | grep -A7 -i "audio":

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
Subsystem: ASUSTeK Computer Inc. Asus A6VC
Flags: bus master, fast devsel, latency 0, IRQ 41
Memory at febfc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel

I tried to mute / unmute all mixer channels (via alsamixer), but it didn't change anything.

Please help me, guys... Thanks

P.S. output from sudo lshw -c multimedia:

  *-multimedia            
   description: Audio device
   product: 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
   vendor: Intel Corporation
   physical id: 1b
   bus info: pci@0000:00:1b.0
   version: 04
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=snd_hda_intel latency=0
   resources: irq:41 memory:febfc000-febfffff
share|improve this question

marked as duplicate by guntbert, Luis Dec 9 '13 at 0:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Maybe this helps askubuntu.com/questions/138266/… –  Misery Apr 6 '13 at 18:25
    
Thank you Misery, I've added that line in my alsa-base.conf and now sound from speakers is working fine!!! But sadly, now headphones audio is mute, why??? –  Balez Apr 18 '13 at 17:01
    
Did you connect headphones to the same plug as speakers? I mean: disconnected speakers and connected headphones in the same place? –  Misery Apr 20 '13 at 5:23
    
No, I use internal speakers (it's a notebook)...anyway yes, I connected headphones in the right input... –  Balez Apr 20 '13 at 20:31
2  
Hi Balez! Welcome to AskUbuntu! Please add your solution as an answer and accept it. Answering your own questions is highly encouraged here to document the solution for others. –  bntser Apr 21 '13 at 20:29

1 Answer 1

A possible solution is disabling "auto-mute" in alsamixer. It is used when the "switch-to-headphone-and-back-again" bug occurs (in high volumes mainly).

First, open your terminal, or press:

CTRL + ALT + T

Then, type and hit "enter":

$ alsamixer

This screen will show up:

Alsa mixer screen in terminal

Use the right arrow until you select "Auto-Mute"

Then, press the down arrow to set it do "Disable" (see the text above it).

That's it.

share|improve this answer
    
It works! Thank you. –  Lukas Stejskal Apr 14 at 20:34
    
You are welcome :) –  Paulocoghi Jun 12 at 13:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.