Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't adjust the screen brightness on my HP 2000-2b09WM 15.6-Inch Laptop. Everything is standard on this machine. I have absolutely no idea where to start. Any help would be welcome, as I can only get about 3 hours of battery life as is. I was getting almost 5 hours on windows 8, with the screen as dim as it could get. I use this machine to take notes in school and do assignments between classes, and finding an outlet isn't always an option, but neither is booting back into windows, gross.

edit: I hope this goes without saying, but I've tried the brightness buttons on my keyboard as well as trying to adjust the brightness in the settings. I'm using the cinnamon desktop, if that makes a difference, but the problem is still there with unity.

share|improve this question

2 Answers 2

I had this problem for some time and I found the solution for my HP ELitebook. My problem was graphics driver.

Screen brightness hot keys did work, but brightness didn't change. In this case you don't need to change grub file...

Hotkeys: To set brightness hotkeys you can use Global Keyboard shortcuts KDE control module. In section KDE Daemon you can set keys for Decrease/increase monitor brightness

This should change current value that in file: /sys/class/backlight/acpi_video0/brightness

echo 7 > /sys/class/backlight/acpi_video0/brightness

will change current brightness to 7.

If all this works but brightness still doesn't change, then you have the same problem as I had: drivers.

Your Laptop is using AMD Radeon HD graphics driver and you'll have to download latest driver here:

http://support.amd.com/us/gpudownload/Pages/index.aspx

To install driver First remove old stuff by:

sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo dpkg-reconfigure xserver-xorg

then install your new driver:

sudo chmod 755 ./amd-driver-installer-12-4-x86.x86_64.run
sudo ./amd-driver-installer-12-4-x86.x86_64.run

***VERY IMPORTANT: if/when it gives you the number options like [1] DO NOT HIT ENTER, you must actually enter the number 1 then enter.

sudo aticonfig --initial

There is also a good idea to install "Catalyst Control Center"...

For people with Intel onboard graphics, go to this url to check the solution: http://ubuntuku.org/10/how-to-fix-intel-graphics-issues-in-kubuntu-maverick/

There are also other useful posts on this (add http):

help.ubuntu.com/community/BinaryDriverHowto/ATI ubuntuforums.org/showthread.php?t=2088043 wiki.archlinux.org/index.php/Backlight

The best way to solve problems like this is to narrow down the location of the real problem and not trying everything that you find about topic. Hope that this will help you and others with this problem ;)

Cheers! Gregor

share|improve this answer

To get working brightness key. try following

press Alt+f2 , execute gksudo gedit /etc/default/grub

Change this line

GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

to something like below

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Open a terminal by Alt+ctrl +T, Execute sudo update-grub and reboot . See if brightness keys are working.


If the above is not working set a fixed value for brightness. To do so,

Open a terminal by pressing Alt+ctrl+T.

Type ls /sys/class/backlight/*/brightness, copy the outputs to a separate text file

The possibility is there will be two paths,try the following for each path and replace accordingly

example paths will be like

/sys/class/backlight/acpi_video0/brightness

Run following commands in terminal,

  1. For the above path Get the maximum brightness:

cat /sys/class/backlight/acpi_video0/max_brightness

Try a lower value to set the brightness, say output is 16 so I will try with half of it

echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

If this works, make this happen in each login automatically by doing the following

gksu gedit /etc/rc.local

Enter this line just before exit 0. It should look like

echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness
exit 0

Also you can try with xdotool Install xdotool

More info here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.