Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Anything I tried to install I get this error message:

No apport report written because MaxReports is reached already
  Errors were encountered while processing:
  E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried most of the tips people say: apt-get upgrade, apt-get -f install, apt-get update. and I've always got the same error.

share|improve this question

marked as duplicate by Eric Carvalho, Elder Geek, muru, David Foerster, Charles Green Feb 19 at 3:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers 4

With the help of a fellow from lauchpad, I found the solution for my problem. It was related with edition problems of grub.cfg Here is the complete discussion at lauchpad. And the direct link to the solution is here. Well, of course the grub.cfg varies from user to user and so its possible editing errors.

share|improve this answer

i had this issue due to the fact that Boot partition was full

check via

df -h

I free up by removed old kernels

dpkg -l | grep linux-headers-*

sudo dpkg --remove linux-headers-3.5.0-28*

and the image:

sudo dpkg --remove linux-image-3.5.0-28*

Make sure you keep you last two kernels uname -a (well at least the last one but for extra safety last two make sure you set the * right)

share|improve this answer

I had the same problem with dovecot-imapd:

 invoke-rc.d: initscript dovecot, action "start" failed.
dpkg: error processing dovecot-imapd (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:

I tried apt-get upgrade, apt-get -f install, apt-get update, apt-get clean, apt-get autoclean, and nothing worked.

Suddenly I realized dovecot-core was still installed and after I uninstalled dovecot-core it work.

So Always check for other dependencies :)

share|improve this answer


sudo apt-get clean

sudo apt-get autoclean

then try again.

Hope it works.

share|improve this answer
could you please explain what they are and what they will do to help the OP problem. –  Raja Apr 1 '13 at 13:15
If the packages are corrupt, they would cause this error of not being able to install, so if we got rid of the bad packages and re-downloaded them, then it should then work when you re-download them. Basicly, it gets rid of the packages in cache. –  user133987 Apr 1 '13 at 13:18
thank @user133987 but unfortunately it didn't work –  ziulfer Apr 1 '13 at 14:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.