Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Unity and GNOME 3 at same time

Unity and GNOME 3 at same time screenshot

My Ubuntu seems to run Unity and GNOME 3 at exactly the same time. Sure, I like it, but is there a way to remove Unity launcher?

share|improve this question
up vote 2 down vote accepted

Looks like the program unity-2d-panel is running at login, start up startup applications and uncheck it. If it doesn't appear run this from a terminal: sudo sed -i "s/NoDisplay=true/NoDisplay=false/g" /etc/xdg/autostart/*.desktop and logout and in again before restarting startup applications.

share|improve this answer
Also greetings from a fellow imgurarian! – w4etwetewtwet Apr 1 '13 at 11:08
Thank you man, that worked perfectly. Someone must of snuck onto my laptop and added unity to startup. Ah well, it's all better now. – Sarger001 Apr 1 '13 at 11:14
@Sarger001 - the way you mark the Q as solved is to click the tick mark next to the answer that helped you. – fossfreedom Apr 1 '13 at 11:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.