Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

That is suppose you have google chrome open or some other program how can we get the unity launcher to autohide when it (the program) is open and maximised but to reappear when it's unmaximised (i.e. it doesn't cover the entire desktop). I am running 12.10

share|improve this question

marked as duplicate by Eliah Kagan, Kevin Bowen, Thomas W., AgentCool, Basharat Sialvi Apr 2 '13 at 9:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

Short answer: you can't, or at least not by default. However, if you install Unity Tweak Tool, I think it may let you do this.

share|improve this answer
    
They removed that capability from Unity itself, so Ubuntu-Tweak can't do it. –  jesusiniesta Apr 1 '13 at 10:36
    
@jesusiniesta Had a feeling that was the case, I'll edit my answer. –  handuel Apr 1 '13 at 10:42

You can't. You can either let the launcher hide always, or never. "Intellihide" and "dodge windows" are removed from unity since ubuntu 12.10

share|improve this answer

They removed that capability from Unity, as far as I know, so as handuel said: you can't... but.

There is thogh a custom build of unity that re-enable a similar behaviour, in which the dock will hide only when it would collide with a window. This is not official code from Canonical, but it comes from an, IMHO, very reliable source, webupd8.

You can install such a patched version of Unity (from webupd8 great repositories):

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update

And then, to get the "real" Unity Dodge Windows

sudo apt-get install unity-dodge-windows

Once installed, press ALT + F2 and run:

unity-dodge-windows

Source, from webupd8: http://www.webupd8.org/2013/02/how-to-get-unity-launcher-window-dodge.html

share|improve this answer
    
I'm afraid this does not solve my problem. The unity launcher disappear indiscriminately, i.e. it does not reappear when all windows are out of its way or even when they're all minimised. I went to alter the behaviour of the unity launcher with System Settings -- Appearance and this failed because when I switched the launcher not to autohide it immediately reverted back to autohide. Plus the launcher still reappears when I go to the left-hand corner of my page even when other programs are overlapping it. –  Brenton Horne Apr 1 '13 at 11:43
    
Sad to hear that. Did you try setting "Have file manager handle the desktop" to OFF? –  jesusiniesta Apr 1 '13 at 12:08
    
I'm afraid it still has this problem even after this adjustment –  Brenton Horne Apr 1 '13 at 12:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.