Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a VPS with ubuntu server 10.04 installed on it.Now I want to have some shell users with limited home folder size.

It seems quota is the best way to do this, but all tutorials require editing /etc/fstab and add usrquota or grpquota to /home partition options.

As my /etc/fstab looks like this:

proc  /proc       proc    defaults    0    0 
none  /dev/pts    devpts  rw          0    0

how can I apply quota?

share|improve this question
add comment

1 Answer

Your VPS provider may be doing tricks at boot-time resulting in your /etc/fstab not needing the root filesystem listed. You can find the device and other details from the output of the mount command. If you add those details to your /etc/fstab, you may be able to add the usrquota,grpquota options there for the next reboot.

If that doesn't work for your VPS, you may be able to approximate those mount options by turning them on later in the boot process. For example, I use usrjquota=aquota.user,jqfmt=vfsv0 on an ext3 filesystem. If I didn't have access to my /etc/fstab, I might try editing my /etc/rc.local and adding something like:

mount -o remount,usrjquota=aquota.user,jqfmt=vfsv0 /that/filesystem
share|improve this answer
    
Thanks for your answer.here is the line related to the root partition in mount command output: "/dev/vzfs on / type vzfs (rw)".Should I add "/dev/vzfs / ..." to the fstab file? –  Pedram Feb 27 '11 at 19:38
    
It may help, but probably not. Try using the rc.local approach instead. –  Kees Cook Mar 5 '11 at 0:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.