Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Ubuntu 12.10 and by the way my wireless is not working. So, I'm trying to fix this problem manually. I have installed the 64 bit Ubuntu already. The problem is I cannot install any packages because when I do I get an error. For example if I run thus command sudo dpkg -i wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb, I get this error:

dpkg: error processing wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb (--install: package architecture (amd64) does not match system (i386)

I also get this error if I try to install any package. My system is a Dell 3421 which has an i5 processor so I don't know why Ubuntu think I have a i386 system. If I run the uname command I get these results:

uname -i 
i686

uname -p
i686

uname-m
i686

Thanks in advance for any help.

share|improve this question
1  
what is the output of uname -a ? – fossfreedom Apr 1 '13 at 9:37
    
Linux my6543-Inspiron-3421 3.5.0-17-generic #28-Ubuntu SMP Tue OCT 9 19:32:08 UT C 2012 i686 i686 i686 GNU/Linux – GeorgeJ Apr 1 '13 at 9:54

The different variants of uname gives an indication of the kernel that you have installed.

This in turn gives a clue as to the version of Ubuntu you have installed as well as the explanation of your error

error: package architecture (amd64) does not match system (i386)

On a 64bit install you would expect something like:

Linux emachine 3.5.0-26-generic #42~precise1-Ubuntu SMP Mon Mar 11 22:17:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

The key part is x86_64 which indicates a 64bit installation.

Your output - i686 indicates that you have installed a 32bit version of Ubuntu.

Some useful links at the end - suffice to say - you cannot install a 64bit debian package on a 32bit system. That is what your error message is basically informing you.

You'll need the 32bit variant of the package - it usually ends with the name i386.deb.


Useful links:

share|improve this answer
    
I double checked and you are right. I downloaded and installed the i386 version. Thanks a lot. – GeorgeJ Apr 1 '13 at 10:42

The answer lies hidden in the documentation of dpkg

dpkg --print-architecture

will show you the architecture dpkg is willing to install packages for.

If the architecture amd64 is not listed, an amd package will be refused, even if all else seems fine. Now you can try to add it by

dpkg --add-architecture amd64

and show it by

dpkg --print-foreign-architectures

On a system that was clearly installed as amd64, I had success in making dpkg trying to install the package. Of course further problems may be detected, such as failed dependancies.

Albert

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.