Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Not sure why my printer suddenly stopped printing. I have a Brother HL-2270DW connected via USB.

The /var/log/syslog show the the following when I unplug and replug the USB cord in. The only thing that really sticks out to me is: udev-configure-printer: failed to claim interface

Mar 31 19:21:54 spaceship kernel: [  592.888013] usb 1-1: new high-speed USB device number 6 using ehci_hcd
Mar 31 19:21:55 spaceship mtp-probe: checking bus 1, device 6: "/sys/devices/pci0000:00/0000:00:02.1/usb1/1-1"
Mar 31 19:21:55 spaceship kernel: [  593.022311] usblp0: USB Bidirectional printer dev 6 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0042
Mar 31 19:21:55 spaceship mtp-probe: bus: 1, device: 6 was not an MTP device
Mar 31 19:21:55 spaceship udev-configure-printer: add /devices/pci0000:00/0000:00:02.1/usb1/1-1/1-1:1.0
Mar 31 19:21:55 spaceship udev-configure-printer: device devpath is /devices/pci0000:00/0000:00:02.1/usb1/1-1
Mar 31 19:21:55 spaceship udev-configure-printer: Device vendor/product is 04F9:0042
Mar 31 19:21:55 spaceship udev-configure-printer: add /devices/pci0000:00/0000:00:02.1/usb1/1-1/1-1:1.0/usb/lp0
Mar 31 19:21:55 spaceship udev-configure-printer: failed to claim interface
Mar 31 19:21:55 spaceship udev-configure-printer: device devpath is /devices/pci0000:00/0000:00:02.1/usb1/1-1
Mar 31 19:21:55 spaceship udev-configure-printer: MFG:Brother MDL:HL-2270DW series SERN:- serial:E2N539264
Mar 31 19:21:56 spaceship kernel: [  594.102843] usblp0: removed
Mar 31 19:21:56 spaceship udev-configure-printer: add /devices/pci0000:00/0000:00:02.1/usb1/1-1/1-1:1.0/usb/lp0
Mar 31 19:21:56 spaceship kernel: [  594.108433] usblp0: USB Bidirectional printer dev 6 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0042
Mar 31 19:21:56 spaceship udev-configure-printer: URI contains USB serial number
Mar 31 19:21:56 spaceship udev-configure-printer: URI match: usb://Brother/HL-2270DW%20series?serial=E2N539264
Mar 31 19:21:56 spaceship udev-configure-printer: device devpath is /devices/pci0000:00/0000:00:02.1/usb1/1-1
Mar 31 19:21:56 spaceship udev-configure-printer: Device already handled
Mar 31 19:21:56 spaceship udev-configure-printer: Consider also queues with "/usb/lp0" or "/usblp0" in their URIs as matching
Mar 31 19:21:56 spaceship udev-configure-printer: URI of print queue: usb://Brother/HL-2270DW%20series?serial=E2N539264, normalized: brother hl 2270dw series serial e2n539264
Mar 31 19:21:56 spaceship udev-configure-printer: URI of detected printer: usb://Brother/HL-2270DW%20series?serial=E2N539264, normalized: brother hl 2270dw series serial e2n539264
Mar 31 19:21:56 spaceship udev-configure-printer: Queue ipp://localhost:631/printers/HL2270DW has matching device URI
Mar 31 19:21:56 spaceship udev-configure-printer: Re-enabled printer ipp://localhost:631/printers/HL2270DW

lsusb sees the printer:

root@spaceship:/var/spool/cups# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 04f9:0042 Brother Industries, Ltd 
Bus 004 Device 002: ID 045e:0084 Microsoft Corp. Basic Optical Mouse
Bus 003 Device 002: ID 046d:c313 Logitech, Inc. Internet 350 Keyboard

And the printer is still visible via CUPS by going to: http://localhost:631/

But regardless no jobs actually come out. What else can I check on this sucker?

share|improve this question
    
I have a printer of the same model and I get the same failed to claim interface message in the syslog when I connect my printer, which prints fine. So I don't think that message indicates a problem. –  Travis G. Apr 3 '13 at 1:14
    
Bummer, Im going to try and reinstall the drivers, think I can just lay them over the ones already installed? –  ProfessionalAmateur Apr 3 '13 at 6:12
add comment

1 Answer 1

up vote 0 down vote accepted

I ended up running this script from the Brothers Website and it corrected the issue.

After I ran the script it auto-added a second printer to the one I already had installed, so I deleted the new printer and the one I originally configured started to work again.

Not sure what broke it, probably and update somewhere but Im back in business.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.