Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to build an ubuntu embedded linux kernel for Beaglebone.

Part of the build has a dependency for ia32-libs. When I try to install it it say it needs ia32-libs-multiarch.
But it says its not installable! (see below). I have tried other solutions from this forum without success.

Can someone explain what is happening and what I can do about it?

ian@ubuntu:~/beaglebone2/linux-dev$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch but it is not installable
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
related: askubuntu.com/questions/216998/broken-packages you may also wish to review: askubuntu.com/questions/143904/… –  Elder Geek Jun 24 at 19:18

1 Answer 1

You can find an answer here What happened to the ia32-libs package?

You can still install it using synaptic

sudo apt-get install synaptic 

then just find your package there

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.