Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there a way to set the screen brightness on a Samsung R519 with Ubuntu 9.10 and the nvidia drivers?

I know that there is a way when using voRia's repository and the nouveau drivers. But switching between one and dual-screen mode takes too much time for daily use on a notebook.

share|improve this question

4 Answers 4

up vote 1 down vote accepted
  1. Open System → Administration → NVIDIA X Server Settings
  2. Go to X Screen → X Server Color Correction
  3. Set the Brightness to your liking.
  4. Confirm the change by clicking on "...seconds to confirm"
share|improve this answer
    
Thanks for the answer, but this one doesn't actually decrease the energy consumption for the notebook, which is also important to me. –  keyboardsurfer Aug 20 '10 at 20:58
    
Well, you didn't ask about decreasing energy consumption, you asked about changing screen brightness :) See my other answer. –  Li Lo Aug 20 '10 at 22:10
    
You're right. For decreasing the brightness this method works for the Samsung R519. I'll ask for energy consumption as well next time ;) –  keyboardsurfer Aug 22 '10 at 15:39
    
Doesn't the method in my other answer change the brightness as well as change energy consumption? –  Li Lo Aug 22 '10 at 16:14

I made a project on code.google.com (script for this issue)

http://code.google.com/p/ubuntu-brightness-laptop-r519/

Just follow README.

share|improve this answer

If you are using the proprietary drivers, you can install a program called nvclock (to do this you can search nvclock in the Ubuntu Software Centre).

You can then go to System -> Preferences -> Keyboard Shortcuts and create 2 new Actions (brightness-up and brightness-down). Set the commands to nvclock -S +5 and nvclock -S -5 respectively. Next choose a shortcut for each command. Normally, you can use your brightness fn keys to do this (eg. on my laptop fn+F7 and fn+F8). shortcuts brightness-up brightness-down

You can then use these shortcuts to change the brightness.

At any time you can press alt-f2 and enter: nvclock -S x where x is a number that is the percentage screen brightness; eg. nvclock -S 100 sets maximum brightness. You can bind these to shortcuts too and use a terminal instead of Alt-F2 if you wish.

You can find out more about how to use the nvclock command by entering man nvclock in a terminal.

share|improve this answer
    
Sounds good, but i get this message: Unable to shadow the video bios It seems your card isn't officialy supported in NVClock yet. The reason can be that your card is too new. If you want to try it anyhow [DANGEROUS], use the option -f to force the setting(s). Also please email the author the pci_id of the card for further investigation. I'm mailing the author my pci_id at the moment and wait for what he says: Card: Unknown Nvidia card Architecture: GA8 A2 PCI id: 0x0 GPU clock: -2147483.750 MHz Bustype: PCI -- Memory info -- Amount: 512 MB Type: 128 bit SDR Clock: -2147483.648 –  keyboardsurfer Aug 20 '10 at 20:45
    
Do you know the exact model of your graphics card? It's possible that your particular card isn't supported. You could also try using nvclock -f -S +5 and nvclock -f -S -5 although you have been warned that this could be dangerous. I can't think, however, that this could cause any damage using the smart dimmer - it is probably more likely a danger if you are overclocking the card (which I wouldn't recommend anyway) –  dv3500ea Aug 20 '10 at 20:54
    
It seems to be a NVIDIA GeForce G105M 512MB VRAM card. When calling nvclock with the -f option it doesn't work and tells me "Unable to shadow the video bios Error!" –  keyboardsurfer Aug 20 '10 at 21:03
    
It seems you're out of luck with this solution :(. Hopefully someone else will have a solution to this problem or a different way to change the brightness. In the meantime, it would be useful if you reported a bug <bugs.launchpad.net/ubuntu/+source/nvclock>; –  dv3500ea Aug 20 '10 at 21:28
    
Aaargh... Thanks. Bug reported as bugs.launchpad.net/ubuntu/+source/nvclock/+bug/622283 –  keyboardsurfer Aug 22 '10 at 15:32

sudo setpci -s 00:02.0 F4.B=42 (lowest level)

sudo setpci -s 00:02.0 F4.B=FF (highest level)

using the following table:

(based on: /proc/acpi/video/GFX0/DD03/brightness )

Brightness  %      HEX  
26          30     42  
34          40     56
44          50     70
57          60     92
69          70     AF
80          80     CC
90          90     E5
100        100     FF

More details at http://pimslinuxlab.wordpress.com/2009/12/25/setting-the-display-brightness-on-a-samsung-r519-laptop/

share|improve this answer
    
Yeah, I already tried this one, but it doesn't work either. –  keyboardsurfer May 31 '11 at 8:59
    
I did basically the same thing on my desktop but it didn't work: unix.stackexchange.com/questions/13196/… –  Syzygy Sep 20 '11 at 3:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.