Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to run Huawei E173 device on Ubuntu 12.10. First of all I have tried running it on raw Ubuntu (installed via Wubi) without any changes. Device was detected at lsusb as Bus 003 Device 004: ID 12d1:1c05 Huawei Technologies Co., Ltd. E173s 3G broadband stick (modem on) but I cant find it at any /dev/ttyU* path (as I expected at ttyUSB0, ttyUSB1...). Then I tried using trunk NetworkManager and ModemManager, same results. Device was listed on lsusb (that mean usb-modechange is working correctly).

Here is some output that might help You to investigate problem with me:

Syslog output:

Mar 31 16:23:28 ubuntu kernel: [ 1297.127008] usb 3-1: >new high-speed USB device number 6 using xhci_hcd
Mar 31 16:23:28 ubuntu kernel: [ 1297.377948] usb 3-1: >New USB device found, idVendor=12d1, idProduct=1c05
Mar 31 16:23:28 ubuntu kernel: [ 1297.377954] usb 3-1: >New USB device strings: Mfr=2, Product=1, SerialNumber=0
Mar 31 16:23:28 ubuntu kernel: [ 1297.377958] usb 3-1: >Product: HUAWEI Mobile
Mar 31 16:23:28 ubuntu kernel: [ 1297.377961] usb 3-1: >Manufacturer: HUAWEI
Mar 31 16:23:28 ubuntu mtp-probe: checking bus 3, device 6: "/sys/devices/pci0000:00/0000:00:1c.3/0000:05:00.0/usb3/3-1"
Mar 31 16:23:29 ubuntu kernel: [ 1297.561484] usb 3-1: >bad CDC descriptors
Mar 31 16:23:29 ubuntu kernel: [ 1297.561681] usb 3-1: >bad CDC descriptors
Mar 31 16:23:29 ubuntu kernel: [ 1297.561880] usb 3-1: >bad CDC descriptors
Mar 31 16:23:29 ubuntu kernel: [ 1297.562033] usb 3-1: >bad CDC descriptors
Mar 31 16:23:29 ubuntu kernel: [ 1297.562168] usb 3-1: >bad CDC descriptors
Mar 31 16:23:29 ubuntu mtp-probe: bus: 3, device: 6 was not an MTP device
Mar 31 16:23:29 ubuntu kernel: [ 1297.562268] usb 3-1: >bad CDC descriptors

I have also found something strange, after first plug in Huawei E173 device I found some extra logs (from usbcore):

Mar 31 17:03:37 ubuntu kernel: [  109.607001] usb 3-1: >new high-speed USB device number 3 using xhci_hcd
Mar 31 17:03:37 ubuntu kernel: [  109.626461] usb 3-1: >New USB device found, idVendor=12d1, idProduct=1c05
Mar 31 17:03:37 ubuntu kernel: [  109.626467] usb 3-1: >New USB device strings: Mfr=2, Product=1, SerialNumber=0
Mar 31 17:03:37 ubuntu kernel: [  109.626471] usb 3-1: >Product: HUAWEI Mobile
Mar 31 17:03:37 ubuntu kernel: [  109.626474] usb 3-1: >Manufacturer: HUAWEI
Mar 31 17:03:37 ubuntu mtp-probe: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:1c.3/0000:05:00.0/usb3/3-1"
Mar 31 17:03:37 ubuntu mtp-probe: bus: 3, device: 3 was not an MTP device
Mar 31 17:03:37 ubuntu kernel: [  109.668930] usbcore: registered new interface driver cdc_ether
Mar 31 17:03:37 ubuntu kernel: [  109.669473] usb 3-1: >bad CDC descriptors
Mar 31 17:03:37 ubuntu kernel: [  109.669490] usb 3-1: >bad CDC descriptors
Mar 31 17:03:37 ubuntu kernel: [  109.669502] usb 3-1: >bad CDC descriptors
Mar 31 17:03:37 ubuntu kernel: [  109.669518] usbcore: registered new interface driver rndis_host
Mar 31 17:03:37 ubuntu kernel: [  109.681131] usb 3-1: >bad CDC descriptors
Mar 31 17:03:37 ubuntu kernel: [  109.681205] usb 3-1: >bad CDC descriptors
Mar 31 17:03:37 ubuntu kernel: [  109.681266] usb 3-1: >bad CDC descriptors
Mar 31 17:03:37 ubuntu kernel: [  109.681302] usbcore: registered new interface driver rndis_wlan

Thanks in advantage for any hints.

Edit: I have same error (usb 2-3: bad CDC descriptor) while running latest netinstal debian.

share|improve this question
    
did you tried installing its software? –  Sreevisakh Mar 31 '13 at 16:35
    
what software do you mean @Sreevisakh? Mobilepartner for linux? Yes, I have tried with ubuntu and Mobilepartner with no effects. I am thinking about some E173 device mode, mabey something get locked, but why I still could use device on Osx? –  Ernest Mar 31 '13 at 17:28
    
in my system i can only use either network manager or mobile partner at a time.it gives lot of errors sometimes won;t detect sometimes won't connect. But most of the time mobile partner will detect after a restart –  Sreevisakh Mar 31 '13 at 17:33
    
In my case MobilePartner wont work :( –  Ernest Mar 31 '13 at 18:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.