Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HTPC with an IntelHD 4000 chip. The HDMI output is connected to a Pioneer VSX-527 amp which in turn is connected via HDMI to my Samsung HDTV. I previously had Windows7 installed on the HTPC and everything worked, but since I'm a long time Linux user I'm not comfortable using Windows, so I decided to install Ubuntu 12.10.

The problem is that with this setup I have no audio (the video displays perfectly). If I connect the HTPC directly to the TV the audio works perfectly.

I tried all the tips I found online but with zero results.

Any tips?

share|improve this question
add comment

2 Answers 2

I have the same receiver and the same problem. I have discovered that changing the resoultion actually makes the sound work. Setting res to 720p or 1080i gives me sound. Not sure why but it could be some kind of handshaking problem. 1080p is of course prefferable but until someone have found out why, this might help you. I have read on other pages that a hdmi switch could resolve handshaking problems but its a longshot in this case as im not sure thats the problem... Edit: it seems that setting the refreshrate to 24 with xrandr fixes my issue. Try the following command: xrandr --output HDMI2 --mode 1920x1080 --rate 24 If you dont use hdmi 2 you can easily see which one you are using by just typing xrandr .

share|improve this answer
    
I am having the exact same issue, sage Graphics Chipset (an i3 NUC) but with a Pioneer SC-LX86 receiver. Same as Mattias I soon discovered that changing to 1080p 24Hz "fixed" the problem. After some further experimenting, like updating the kernel, using daily alsa builds, trying several other Linux distributions (Fedora 19, Ubuntu 12.10, Arch Linux), I discovered it's a generic issue, they all refuse to play audio when the resolution is set at 1080p with refresh rates of 50Hz & 60Hz, all the other resolution and refresh rate combinations I tried worked fine. –  user173297 Jul 7 '13 at 13:44
    
Brilliant! Thanks a lot. Same problems here, with an i5 NUC, and a VSX-70 receiver. I can't believe this question+answer hasn't been voted up more! –  Dustin Kirkland Mar 7 at 7:24
add comment

Check your graphics driver since HDMI is a digital signal for both audio and video. If you type

 aplay -l, 

you should see all your audio outputs. If your HDMI output is not listed, then it is probably a driver issue. If it is listed, try using aplay commands to play a file to check if it is working. This looks something similar to

aplay -D hw:0,0 /usr/share/sounds/alsa/Front_Center.wav
share|improve this answer
add comment

protected by Community Jul 7 '13 at 14:28

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.