Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 12.10 on my LG S900 laptop (dual boot with Windows 7). But when I try to type something with the keybaord nothing happens (but the touchpad works). The keyboard did not work during the installation but i could use Onboard to finish it. Any suggestion on how I can get the keyboard to work?

share|improve this question
    
Output of lsusb? And lspci? –  nerof61 Mar 31 '13 at 15:07
    
Thanks. lsusb and lspci both detect mouse, but no keyboard... –  nerof61 Mar 31 '13 at 15:59
    
Could you collect the output of "sudo dmidecode" from your LG labtop? Thanks, –  user269346 Apr 16 at 0:07

3 Answers 3

up vote 1 down vote accepted

I found a working solution to the problem.

  1. You need to edit the file /etc/default/grub

    $ sudo gedit /etc/default/grub

  2. Go to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and edit it to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp=1 i8042.dumbkbd=1"

  3. Update grub

    $ sudo update-grub

  4. Reboot your computer.

Source

share|improve this answer
    
I was editing the answer on mine! Oh, well. ;-) –  nerof61 Apr 7 '13 at 13:12

I had the same issue with an LG R405 laptop when upgrading from 13.04 to 13.10. No response at all using internal keyboard. The solution with adding "i8042.nopnp=1 i8042.dumbkbd=1" in /etc/default/grub worked great for me.

share|improve this answer
    
Yeah, this worked for me as well. Actually, I only used the "i8042.dumbkbd=1" part, as instructed here: groups.google.com/forum/#!msg/linux.kernel/0NdfVkltWGs/… –  pagliuca May 6 at 4:17

You will need to connect a wired keyboard for this to work. If the keyboard works in Windows, it might be usable at the BIOS screen.

During the POST (Power On Self Test), when the PC is running up for a power-on or a reset, the USB keyboard input is managed by the BIOS routines, if set up to do so. If not, there is no way the USB keyboard can be recognised and a PS/2 type keyboard is expected to be connected to its port by default instead.

As long as your USB keyboard isn't recognised, you aren't able to access the BIOS so you can't do anything else as to connect a PS/2 type keyboard, access the BIOS...

BIOS

...by the use of [Del], [F1], [F2], [F9] or whatever key is indicated at the early stages of the start-up process of the PC,

Bios USB

and enable the "USB keyboard support" or "USB legacy support" option that can be found in the BIOS.

Save, exit and reset. If, in spite of the precedent set-up, the BIOS continues refusing to recognise the USB keyboard (e.g. you can't go into the BIOS by pressing the correct key on the USB keyboard) you have a second chance to convince it to.

Use the PS/2 keyboard to enter the BIOS again,

Bios 3

and look at the "PnP mode" option. PnP is the procedure to set-up extension cards and some on-board' chips connected to the PCI bus. As USB controllers in your computer (both on-board as the eventually added expansion cards) are connected to the PCI bus, they have to be set-up by the BIOS to have the USB keyboard working at the early POST phase.

There are two configuration modes available for PnP:

  • the BIOS has to manage the PnP setup;

  • the operating system deals with the PnP setup.

You have to explicitly specify the BIOS has to manage the PnP mode (and not the operating system), to obtain the USB keyboard recognised during this phase.

Verify this and, on change, save, exit the BIOS and reset the PC to control if the USB keyboard is now alive.

(Situation 2.) When the boot manager's menu' appears on the screen no key on the USB keyboard enables you to move the selection to one different item from the default one that will start the boot automatically after a few seconds.

This means that you haven't successfully managed the instructions in "situation 1."!

It must be clear that no boot manager loads any keyboard device-driver so it expects the BIOS to manage the USB keyboard correctly!

During this stage the o.s. hasn't been already loaded so no change to the o.s. configuration will solve the problem!

You have no choice, go back to Case 1., and work to solve the situation from there.

(Situation 3.) So you have managed to get the USB keyboard recognised by the BIOS, and in Grub (or LiLo) you are able to select a choice different from the default by the use of the up/down arrows keys.

After a not so long time (we hope), the log-in screen appears but you discover to be unable to write any character into the user/password fields, or if you started from a live CD-R/DVD and you aren't able to write with your keyboard to any application you run from the desktop.

From this point on, problems related to the USB keyboard have to be conducted, in some way, to the Linux operating system configuration issues (and in rare cases to bugs).

In this case, the principal sources of the problem to be searched in are:

incorrect o.s. setup files for character mode terminal emulation (e.g. the recovery mode in *ubuntu);

incorrect window server setup files for graphic windowing environment (when the windowing mode is run, e.g. Xwindow in Linux)

missing, wrong, bugged keyboard device drivers;

unsupported USB devices.

As stated before this case isn't covered in this document. This because the verifications/operations to be made to get the USB keyboard working are so many and depending from e.g. the window manager used, to justify separate documentation.

Hope this helps!

(Source of information: here.)

share|improve this answer
    
Thank you for the detailed answer. i will try this as soon as i can. unfortunately I don't have an external keyboard at this place so I have to wait until next week to try it. –  FredN Mar 31 '13 at 17:01
    
See if the keyboard works on start-up. It's a possibility. And, if you think it works, you could accept it. –  nerof61 Mar 31 '13 at 17:16
    
@FredN - Did it work? –  nerof61 Apr 1 '13 at 11:15
    
I can use the keyboard to choose the OS I want to use in grub2 menu. But I cannot get to the bios menu before that for some reason.. –  FredN Apr 1 '13 at 11:44
    
Before you turn on your PC, try tapping (A lot) F12/What your BIOS key is. While doing this, turn on your PC. Keep on tapping. You should enter the BIOS. –  nerof61 Apr 1 '13 at 11:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.