Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Linked question (but not duplicate): Problem deleting broken files on external drive

My External HD is working fine except for one file that I can't delete.

My guess is that there was a power failue or an accidential unplugging while this file was saved. It is now impossible to delete it or the directory that contains it, it is also present in multiple copies in .Trash-1000/expunged with names that are only 9-10 digits numbers.

I tried to follow the procedure described in this solution, but fsck returns

fsck: fsck.ntfs: not found
fsck: error 2 while executing fsck.ntfs for /dev/sdb1

I don't care about that file and I would be happy to remove it, I just can't afford to lose the rest of the files.

Is there a command, a software or a trick to delete it?

share|improve this question
    
Have you checked the permissions on the file(s)? –  Mitch Mar 31 '13 at 8:20
    
Yes, I checked, I tried to sudo the delete, to open nautilus with sudo, to erase it from a liveCD, nothing works. –  Oltarus Mar 31 '13 at 19:58
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.