Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got Steam from the Ubuntu Software Center, and it asked me to reopen steam to finish the installation. When I opened it up, I got a terminal that said the following:

Steam needs to install these additional packages: 
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386
[sudo] password for michael:

When I go to type in my password in the terminal, it isn't registering that I am typing my password in and it is staying blank. I tried a fresh terminal window to see if I could type in that one and I could, and everywhere else I can type except for the Steam install terminal which is called "Package Install".

I have tried to reset my machine a couple of times to see if that would fix the problem and it didn't. Does anyone know what the problem might be? Thank you for taking the time to read all of this.

share|improve this question

I just got the same problem on Debian. This is not about hidden password input. The terminal doesn't response to Enter either. The solution is to close the window and install required packages manually:

sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libc6:i386

Then launch steam again, and the terminal won't appear.

share|improve this answer

Terminal dosn't show key presses, or stars for password. (So you won't see it typed, it will seem like nothing is happening, this is a security feature so others can not know the length of the password)

So keep typing and then hit enter once you have entered your password.

Also note: This will be your Ubuntu system password.

If the install fails you may want to install the packages Steam says it needs through the software center or synaptic package manager.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.