Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

xlog when working as expected, outside of the Unity environment

I'm the newly appointed application maintainer for a program called "xlog". The program works fine in all but the Unity environment. It is written using Gtk2.

I've never previously used Unity. I noticed in Unity that the menu bar seems to be "redirected" to another place outside of my application GUI, to a bar at the top of the screen. Secondly, one of the text entry boxes in my GUI is displayed as a thin line, unaccessible to the user except via the tab key.xlog in unity - note the missing menu bar, and the remarks box isn't a box.

If I take the xlog executable that works perfectly under Ubuntu 12.04.2 LTS and copy it to a 12.10 Unity distribution, I see the different behavior.

I haven't a clue where to look, or what I should consider modifying, in the xlog application, to remedy this situation. What's different in Unity that is unique to all other environments where this application works properly?

share|improve this question
    
It may be advantageous to upload a couple of screenshots to highlight the issue. –  Oli Mar 30 '13 at 22:28
    
Oli: It isn't obvious to me how to upload the screenshots. This is my first time using this website. –  Andy Stewart Mar 30 '13 at 22:34
    
Click the edit link, click the place in the post you would like the image to appear and then click the little icon in the toolbar that reads img. A pop-in should appear. Follow the prompts. –  Oli Mar 30 '13 at 22:36
    
I tried that, Oli, but it says I need "10 reputation" to post images. –  Andy Stewart Mar 30 '13 at 22:40
    
OK, now it is letting me post images - thanks! –  Andy Stewart Mar 30 '13 at 22:49

1 Answer 1

up vote 10 down vote accepted

I noticed in Unity that the menu bar seems to be "redirected" to another place outside of my application GUI, to a bar at the top of the screen.

I think what you are refering is the default behavior on Unity. Unity uses a global menu (the one you see at the top) similar to what is seen on OSX.

Unity app menu in action.

If you want this can be disabled in your application, but I think that is not very recommended: anyone using Unity will expect the menu not on the window, but at the top.

Regarding the entry box I would guess that it may be a problem with the Ubuntu theme. To check it try to change the Ubuntu theme (under "System Settings" -> "Appearance") and see if the box stays the same.

Edit

I was curious and looking at the code it seems that the problem is in your application.This seems to fix the issue (I can't enter a newline on that box, but I can't say if this is normal or a bug). Those values (100, 200) were selected randomly so this may not be the best way to solve that.

enter image description here

share|improve this answer
    
Thanks, Salem. With the "High Contrast" theme, the Remarks box is displayed properly. With the default Ambience theme, the Remarks box is not correctly displayed. –  Andy Stewart Mar 30 '13 at 22:45
    
@AndyStewart see my edit. –  Salem Mar 30 '13 at 23:30
    
Salem, I tried it locally and I see the differently sized remarks box. I put the executable into my Virtual Box version of Ubuntu with Unity, and see that now the remarks box is behaving as expected. I'll look at the inability to enter a <cr> - that behavior exists prior to your suggested modification. Thank yoU!!! You've been very helpful. 73 de Andy KB1OIQ –  Andy Stewart Mar 30 '13 at 23:50
    
I just released xlog 2.0.7 with this fix. Thanks, Salem, for your help! –  Andy Stewart Mar 31 '13 at 0:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.