Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on a HP Pavilion DV6-2170US, running 32-bit Ubuntu 12.10. When I plug in my headphones the speakers AND the headphones play sound at the same time. The speakers should stop playing and send all sound to the headphones. How can I configure the sound that when I connect my headphones the speakers in the laptop are muted and the sound only comes out to the headphones.

I should mention that this model provides 2 audio output connections in the front (Not just one like most laptops).

Here is an image of how the Sound Settings looks:

enter image description here

Thanks!

share|improve this question
add comment

2 Answers

I would first check to see if Ubuntu is detecting both (Headphones and Speakers) in the system settings:

enter image description here

If you see something like one the following images, then you know both were detected:

enter image description here

enter image description here

In my case I have support for my headphones and my stereo output. If in one case I would like to disable sound for the speaker, I would first select the output I want to disable and then disable the option (Marked by the green circle). This way sound will not come out of that output connection. The same goes for input devices. Here is another image of how 12.10 looks. Notice that I have both, the Speakers connection (Analog Output) and the Headphones:

enter image description here

The same case applies here. You select the device you want to mute and click on the mute button.

For cases where this options do not show or sound is still coming from the speakers when you have your headphones connected then follow this steps:

  1. Type in dash terminal or ter for short and press Enter

    enter image description here

  2. In the terminal type alsamixer and press Enter

    enter image description here

    enter image description here

  3. Inside the alsa mixer app, using your arrow keys, move left or right to any of the options that will show in your mixer window. Pressing up or down you can adjust the volume for that specific connection or pressing M you can mute the connection. What you will be doing here is looking for the one that mutes your speakers but leaves your headphones still with sound.

Now for your case, it seems your headphones are not getting detected correctly. The only option your computer shows is "Speakers" which are the internal ones. When you connect the headphones, the sound comes out of both (Speakers and Headphones) because it thinks they are the same. If you have already upgraded Ubuntu I would suggest to see what the command dmesg outputs. Type dmesg on a terminal and see if there is anything related to sound.

UPDATE: After looking at your dmesg and other information (Provided by Mr Jeeblez himself) and seeing that you have the Intel 5 Series/3400 Series Chipset High Definition Audio, searching I found a bug report that was made for said motherboard. You can find the bug report in https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/580233

The solution was to do the following:

  1. In the terminal type: sudo gedit /etc/modprobe.d/alsa-base.conf

  2. At the end of the file paste the following:

    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell-m4-1 enable_msi=1

  3. Save and Reboot.

NOTE: If this does not work, change in the second line the part about:

model=dell-m4-1 --> model=hp-m4.

share|improve this answer
    
What using dmesg said –  MrJeeblez Mar 31 '13 at 16:21
    
Results from that command –  MrJeeblez Mar 31 '13 at 21:11
    
@MrJeeblez - Sorry for the delay. After doing some more research I found other users with similar problem and a possible solution. Try it out and tell me if it works. –  Luis Alvarado Apr 2 '13 at 21:44
add comment

I had the same problem on a System 76. It worked properly in 12.04, not in 12.10. I tried all these settings, but it never worked properly.

It works in Ubuntu 13.04 without me having to do anything.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.