Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after an interrupted upgrade of ubuntu 10.04 server LTS to ubuntu 12.04 server LTS somethings weren't installed correctly. Anyways I installed apache, ftp, phpmyadmin etc. At some point I deleted some packages that were causing problems and that messed up my mysql and phpmyadmin installation. Now I can not install mysql and phpmyadmmin. I get the following error trying to install mysql:

The following packages have unmet dependencies:
mysql-server-5.1 : Depends: mysql-client-5.1 (>= 5.1.67-0ubuntu0.10.04.1) but it is not      going to be installed
E: Unable to correct problems, you have held broken packages.

And I get the following error trying to install phpmyadmin:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libxml-libxml-perl : Depends: perl (>= 5.14.2-6ubuntu1) but it is not going to be installed
Depends: libxml-namespacesupport-perl but it is not going to be installed
libxml-sax-expat-perl : Depends: perl but it is not going to be installed
Depends: libxml-namespacesupport-perl (>= 0.03) but it is not going to be installed
Depends: libxml-parser-perl (>= 2.27) but it is not going to be installed
libxml-sax-perl : Depends: perl but it is not going to be installed
Depends: libxml-namespacesupport-perl but it is not going to be installed
Depends: libxml-sax-base-perl but it is not installable
phpmyadmin : Depends: perl but it is not going to be installed
Recommends: apache2 or lighttpd but it is not going to be installed or                 httpd
Recommends: mysql-client
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question
2  
What command did you run? –  Frederik Spang Mar 30 '13 at 17:02
    
Hi Frederik, thanks for your reply. I runned: sudo apt-get install apache2 But I got apache2, phpmyadmin and mysql-server installed by running the aptitude install apache2 command and looking for an option that would solve unmet dependencies. Now I can't start apache2 service. root@69-64-65-19:~# service apache2 start * Starting web server apache2 apache2: Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/fcgid.load: Cannot load /usr/lib/apache2/modules/mod_fcgid.so into server: –  Abdiel Hernández Fentanes Mar 30 '13 at 20:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.