Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there something I could add to the Exec line ìn gummi.desktop which would do the trick?

[Desktop Entry]
Version=1.0
Name=Gummi
GenericName=LaTeX Editor
Comment=Simple LaTeX Editor
Exec=gummi %F
Icon=gummi
Terminal=false
Type=Application
Categories=Office;
StartupNotify=true
MimeType=text/x-tex;

https://apps.ubuntu.com/cat/applications/precise/gummi/

http://dev.midnightcoding.org/projects/gummi

https://launchpad.net/~gummi/+archive/gummi

share|improve this question
    
If you're running Unity you could try configuring window rules with Compiz. Other window managers offer similar settings. –  Glutanimate Mar 31 '13 at 7:22
    
thx, yes I'm using Unity and am aware of CCSM -- but generally try to keep my usage of it to a minimum... –  nutty about natty Mar 31 '13 at 9:02

1 Answer 1

Please Note: the answer below will work with window managers such as xfwm4, metacity, and others, but will not with compiz, because of the way the desktop and windows are handled (being divided into viewports). As mhc noted, you will have to use ccsm, as explained in comment above, and refer to this askubuntu answer.


You don't need to add anything to the .desktop file, just edit the config file in your home folder.

Find $HOME/.config/gummi/gummi.cfg and set the dimensions to your screen size and it will launch maximised. The dimensions will vary according to your maximum resolution; for example they could be 1280x1024, 1920x1080, etc.

Here is the original section in $HOME/.config/gummi/gummi.cfg.

[Global]
config_version = 0.6.1
mainwindow_x = 244
mainwindow_y = 233
mainwindow_w = 792
mainwindow_h = 558

As an example, I would change 792 and 558 to 1280 and 1024, so that it would launch maximised next time. Edit the file and then relaunch gummi. Whatever you put in will be adjusted by the program when it launches, so don't worry about specifying the exact values.

If you mess up the configuration file, just delete it and it will be respawned when gummi launches.


You could also use devilspie, which is in the repositories.

sudo apt-get install devilspie

Now create a ~/.devilspie folder if it doesn't already exist, and create a profile for gummi, so that when gummi runs, it will trigger devilspie to maximise the window. Name the file gummi.ds and place this in it:

; gummi maximise

(if (is (window_class) "Gummi") (maximize) )

However, devilspie must be added to startup applications, as it needs to be running.

It is worth trying devilspie as it is a very useful application for manipulating chosen windows, but may not work if you are running compiz.

share|improve this answer
    
no dice. set mainwindow_w/h to my max. (and current) resolution, also set mainwindow_x/y to 0. any further ideas? was it a good idea setting mainwindow_x/y to 0? –  nutty about natty Mar 31 '13 at 5:00
    
or - does it require a reboot? (or logout-log-back-in) –  nutty about natty Mar 31 '13 at 5:01
    
@nuttyaboutnatty I edited it- the mainwindow_x, y weren't supposed to be 0. It does work for me- just put your current resolution for the mainwindow w and h and save the file. Then relaunch gummi. Perhaps you have a different window manager than me; I'm on Xfce using xfwm4. –  user76204 Mar 31 '13 at 10:56
1  
@nuttyaboutnatty You can leave it as it is, and remember you can delete it in the future if you ever encounter any problems. –  user76204 Mar 31 '13 at 11:37
1  
@nuttyaboutnatty In my edit I mention devilspie, which is worth trying. –  user76204 Apr 6 '13 at 0:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.