Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have some problems downloading with the sudo apt-get command.

I try to get Java runtime:

Reading package lists... Done

Building dependency tree   

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:  openjdk-6-jre : Depends: openjdk-6-jre-headless (>= 6b27-1.12.3-0ubuntu1~12.10.1) but it is not going to be installed
                 Depends: libgif4 (>= 4.1.4) but it is not installable
                 Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not installable
                 Recommends: ttf-dejavu-extra but it is not installable
                 Recommends: icedtea-netx but it is not installable

Can someone help me, I'm new to Linux/Ubuntu?

share|improve this question

marked as duplicate by Eliah Kagan, Eric Carvalho, Seth, con-f-use, AgentCool Mar 30 '13 at 16:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Sure thing. In the command line type in software-center now search for java. That should fix all your problems.

Also I recomend installing synaptic as your package manager to assist you with individual packages.

share|improve this answer
    
Details: The following packages have unmet dependencies: openjdk-6-jre: Depends: openjdk-6-jre-headless (>= 6b27-1.12.3-0ubuntu1~12.10.1) but 6b27-1.12.3-0ubuntu1~12.10.1 is to be installed Depends: libgif4 (>= 4.1.4) but it is not going to be installed Depends: libjpeg8 (>= 8c) but 8c-2ubuntu7 is to be installed Depends: libpulse0 (>= 1:0.99.1) but 1:2.1-0ubuntu4 is to be installed Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not going to be installed –  fred Mar 30 '13 at 13:46
    
Tried to install synaptic through softwarecenter didn't work aswell. also some packet problems.. –  fred Mar 30 '13 at 13:50
    
sudo apt-get clean will fix any broken packages. sudo apt-get dist-upgrade will force install any packages that won't install. Also check in the software center do you have any kinds of java installed that can prevent other kinds of java packages from installing? That can be found in the installed section. Remove if you do. Your issue might be misplaced repository list or broken packages. –  user140393 Mar 30 '13 at 14:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.